x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Crash (LogWmfMedia: An error occured when preparing the topology)

Hello, I'm having a problem with my (pure blueprint) VR project: While I preview the game in VR Preview in the editor at some point (after 30 seconds to 2 minutes) the application will crash. I've tried deleting Intermediate/Saved folders without success. The project is also building just fine.

The crash reporter is throwing me this:

 Unknown exception - code c0000002 (first/second chance not available)
 
 KERNELBASE
 mfcore
 mfcore
 mfcore
 UE4Editor_WmfMedia!FWmfMediaTracks::AddTrackToTopology() [d:\build\++ue4+release-4.18+compile\sync\engine\plugins\media\wmfmedia\source\wmfmedia\private\player\wmfmediatracks.cpp:990]
 UE4Editor_WmfMedia!FWmfMediaTracks::CreateTopology() [d:\build\++ue4+release-4.18+compile\sync\engine\plugins\media\wmfmedia\source\wmfmedia\private\player\wmfmediatracks.cpp:143]
 UE4Editor_WmfMedia!FWmfMediaPlayer::TickFetch() [d:\build\++ue4+release-4.18+compile\sync\engine\plugins\media\wmfmedia\source\wmfmedia\private\player\wmfmediaplayer.cpp:173]
 UE4Editor_MediaUtils!FMediaPlayerFacade::TickFetch() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\mediautils\private\mediaplayerfacade.cpp:779]
 UE4Editor_Media!FMediaClock::TickFetch() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\media\private\mediaclock.cpp:32]
 UE4Editor!FEngineLoop::Tick() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:3299]
 UE4Editor!GuardedMain() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\launch\private\launch.cpp:166]
 UE4Editor!GuardedMainWrapper() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:134]
 UE4Editor!WinMain() [d:\build\++ue4+release-4.18+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:210]
 UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:253]
 kernel32
 ntdll

In the log (https://pastebin.com/7mJYM2xj) I'm also getting the report

 [2018.01.17-14.34.22:335][679]LogWmfMedia: Error: An error occured when preparing the topology

a couple of times

I think the problem is related to the Media Player. I have two Media Players with two different videos running in my project. They are shown on four screens and can be toggled by the user. The videos play fine, loop fine, toggle screens just fine. They finish and repeat properly. The blueprints are nothing fancy, they just toggle between the videos (Event Tick is set to 3 seconds to sometimes grab a new video).

Here is the Event Graph and the Construction Script. Event GraphConstruction Script

Like mentioned before it packages just fine. And from what I'm observing the crash is not appearing in a packaged version (10+ min and me spamming all functions without problem). Unfortunately I will very likely need to present the project in Editor mode, as weird as it sounds.

Any help would be greatly appreciated!

Product Version: UE 4.18
Tags:
eventgraph-bp.jpg (98.3 kB)
construction-bp.jpg (277.5 kB)
more ▼

asked Jan 17 '18 at 03:09 PM in Blueprint Scripting

avatar image

IntervideoFilm
11 2 5

avatar image IntervideoFilm Jan 17 '18 at 03:33 PM

I actually just tested the project locally (since we use a server) with the media files linked to my local SSD, which seems to work. Not 100% sure. But the problem could have been that the files get streamed from the server. It would explain why the packaged project works.

avatar image gmpreussner STAFF Mar 20 '18 at 07:57 PM

Can you try in 4.19? Thanks!

avatar image srodriguezdiseno Mar 25 '18 at 05:22 PM

I´m getting the same crash over and over, any updates? same setup, I have a UI material playing 2 videos (Opaque and Alpha) an both plays at the same time, the crash happens 1/3 of the execs

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I know this is an old post, but I found I get crashes and LogWmfMedia: An error occured when preparing the topology (in 4.22.1) when the files that the file media source references is not locally in the Content/Movies folder. Fixing that stopped the crashes for me.

more ▼

answered Apr 26 '19 at 09:08 PM

avatar image

Todd.Vance
32 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question