x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why are my shadows disappearing after baking?

I have these static meshes which appear to be rendering fine with the default light and sky, however, after I bake them, the shadows lose much of there form leaving behind only part of the shadow.

The shadows appear fine on the structure to the right of these meshes. They are all static.The light source (default, intensity lowered) is stationary.

Image

Thanks for any help, I have attempted for hours now to correct this with no luck.

Product Version: UE 4.18
Tags:
more ▼

asked Jan 17 '18 at 06:32 PM in Rendering

avatar image

TristonS
44 4 3 7

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Try increasing the lightmap resolution of your landscape (terrain).

BTW, this is a great reference for troubleshooting lights/shadows related issues:

https://wiki.unrealengine.com/LightingTroubleshootingGuide

more ▼

answered Jan 17 '18 at 08:05 PM

avatar image

vr_marco
2.2k 10 6 12

avatar image TristonS Jan 18 '18 at 03:12 AM

Thank you Marco! I had actually used that guide extensively to remove modular seams from my map so that is embarrassing.

I was able to fix my problem by increase "Static Lighting Resolution" from 1 to 4 in the landscapes details.

I could not find a specific setting to change lightmap resolution like you can with static mesh. Was "Static lighting resolution" the correct property to change? (It looks good, just wondering from performance perspective).

avatar image vr_marco Jan 18 '18 at 06:28 AM

Yes, that is the right property to change. There is for sure a small hit on performances, but since the shadows are baked into the lightmap of of the terrain, it is not that dramatic. It is more memory usage. If you would use dynamic lights then that would definitely make a difference.

If you are curious, you can use UE4's profiler to check for performances with lowres shadows and highres shadows, then compare them.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question