x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

PACKAGE MY VR GAME

hello, I finally finished my first VR Game on Unreal and i want to package the whole thing. however I've found a persistent error.. I've been looking thorough this forum and haven't found an answer.. im putting the error message below.

P.S. I want to package the game on windows 64 bytes.

Here's the error log.

https://imgur.com/a/1oeTJ

Product Version: UE 4.18
Tags:
more ▼

asked Jan 18 '18 at 12:03 AM in VR

avatar image

Weeknox
6 1 3 4

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Looks like your Target.cs file has some syntax issues which prevent UAT from compiling it properly. Did you have a look at it? Was it modified by someone?

more ▼

answered Jan 18 '18 at 09:40 AM

avatar image

vr_marco
2.2k 10 6 12

avatar image Weeknox Jan 18 '18 at 02:53 PM

Not at all, I never even touched that file

avatar image vr_marco Jan 18 '18 at 03:00 PM

As Dune suggested below, first make a BACKUP copy of your project, then delete the Saved, Internediate and Build folders from its root. Right click on the .uproject file and select Generate Visual Studio project file. Then open the project and watch the Intermediate files being re-generated. Now try packaging again.

avatar image Weeknox Jan 18 '18 at 03:18 PM

Tried it already, deleted the Saved and Intermediate folder only, cause I couldt find the Build one.. after I did that i tried right clicking to "Generate Visual Studio" but an error window appeared... which is the image below.. after that I just clicked accept and tried to package the game anyway.. same result and error log as before.alt text

capture2.jpg (63.2 kB)
avatar image vr_marco Jan 18 '18 at 03:26 PM

That error is normal because I see that you don't have any Source in your project folder. Since you still get the error, I am thinking that your .uproject file contains some stray dependencies. Can you attached a screenshot of its content? Open it with Notepad.

avatar image Weeknox Jan 18 '18 at 03:33 PM

Sure Marco, here it is... Sorry for all the trouble tough :/ alt text

capture3.jpg (36.6 kB)
avatar image vr_marco Jan 18 '18 at 03:40 PM

Looks ok to me. Here is the next thigh I would try.

Create a brand new empty project. Call it Test. Save it.

Now open this project. Select the level (map) from the browser. Right click and choose Migrate... Migrate the level and all its dependencies to the Content folder of the Test project above.

Open the Test project and try to Package that one. Does it work?

avatar image Weeknox Jan 19 '18 at 03:53 PM

Sorry to tell you Marco but what you ask me is impossible, the map never loads in the other game, I just waited for 2 hours and nothing happened.. any other suggestions?

avatar image vr_marco Jan 19 '18 at 04:38 PM

I believe your project is corrupted beyond repair. One last thing you can try is take the content of the Content folder and copy it to the Content folder of a brand new project. You may be able at least to recover the contained assets, but not sure whether that is going to work. Sorry! You may try to get help directly from Epic. Maybe they have a trick to fix it.

(comments are locked)
10|2000 characters needed characters left

As Marco has said, the Target.cs is the issue and you can open these files from Source->xxxxx.target.cs.

You can also try deleting the intermediate folder and re-generating your project. This should highlight any issues with the .cs file and might get rid of the issues.

more ▼

answered Jan 18 '18 at 10:21 AM

avatar image

Dune
1.9k 52 39 200

avatar image Weeknox Jan 18 '18 at 03:04 PM

Hey Dune, I tried deleting the folder, then restarting unreal so I can package it... Unreal created the file as soon as I re-open it, so with the new file I tried packaging again.. here's the log.. I think it's pretty much the same as the older one.. but I really dont know, would you mind take a look a it please?

https://imgur.com/a/xi15F

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question