x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 & Visual Studio 2017 not opening properly

I have been reading around AnswerHub and Google on this issue I have been having with UE4 and Visual Studio 2017 Community having issues communicating with each other. I have been unable to get a solution to this problem. I have Unreal Engine 4.18.3 installed and Visual Studio 2017 Community (w/ latest update as of 1/19/2018) installed.

When I create a new C++ class inside of UE4 content browser, it will compile the new code files and open up visual studio, but in UE4 you still see the "opening visual studio" at bottom right, if you wait like 10-15 mins then Visual Studio opens up again in another window with the new C++ files. This is slowing down my production time with my work and projects. In the console log in UE4, there are some warning such as "can't find visual studio" (I set it to VS2017 in editor settings). Also, some logs pop up like "Visual Studio is open but could not be queried - it may be blocked by a modal operation" and "Couldn't access Visual Studio" and "Couldn't access module table".

This also creates issues if I close UE4 and/or Visual Studio while it waiting/loading visual studio a second time, it will corrupt the file in which I will have to manually delete it to avoid compile errors and rebuild my projects manually as well. Is this a bug? Admin problem (my pc is admin (just me))? Any solutions?

Product Version: UE 4.18
Tags:
more ▼

asked Jan 19 '18 at 09:41 PM in Bug Reports

avatar image

Oblivion2500
143 16 26 129

avatar image Sean L ♦♦ STAFF Jan 22 '18 at 02:07 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1410408-unreal-engine-bug-submission-form

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question