x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Game Startup excessively slow after update to 4.18

When I coded my game on 4.18 UE , the packaged game starts up quite quickly. However, it became excessively slow after I migrated project from 4.13 to 4.18.

I need 4.18 Engine's new features, so I get confused by above problem.

Something I found:

  1. 4.13 game and 4.18 game startups are both slow at first time running, but at second time 4.13 game Starts up very fast(about 5 seconds) in contrast with 4.18 game (still slow).

  2. 4.13 game second startup barely load assets from disk(there is no disk occupy at task manager) in contrast with 4.18 Game, Which still loads assets from disk and has very high occupy of disk. alt text 4.13Startup

alt text 4.18Startup

Thanks for everyone's help.

Product Version: UE 4.18
Tags:
413startup.png (95.0 kB)
418startup.png (119.2 kB)
more ▼

asked Jan 20 '18 at 04:01 AM in Packaging & Deployment

avatar image

co1or
16 1 4

avatar image Dr. Whoop DSc Jan 31 '18 at 05:38 PM

I'm having the exact same issue after upgrading from 4.15 to 4.18. Similarly the old version often starts slow the first time but then speeds up, the new one remains slow.

My start up log shows

 [2018.01.31-17.27.03:709][  0]LogInit: Texture streaming: Enabled
 [2018.01.31-17.27.13:424][  0]LogUMG: Display: Widget Class Cursor_C - Loaded Fast Template

where nothing seems to happen for 10 seconds and the game is not responding in task manager.

avatar image Raf_L3O Aug 28 '18 at 07:34 PM

Something changed between 4.16 (fast) and 4.18 (slow).

Packaged Shipping Build Load time for our project is 2.2x faster on average in 4.16. On SSD it went from ~25s to ~55s for the initial load time.

We're now testing 4.20.2 and it still suffers from this slow load time. Both Async and EDL are enabled in all version tests.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question