x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't edit the charactor in animation blueprint

the title says most of it. i click on the character in my animation blueprint in Blend space but now i cant. i use to be able to edit him but it just for some reason stopped. im also a beginner to Unreal Engine 4.

Product Version: UE 4.18
Tags:
more ▼

asked Jan 21 '18 at 10:30 PM in Blueprint Scripting

avatar image

Gos2002
26 3 9 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hi ,

I guess what you are missing is bone view, to you can make a pose by rotating mesh etc ...

alt text

follow these steps and you will be able to edit the character.

let me know if it works ,,

thanks

showbone.png (263.9 kB)
more ▼

answered Jan 25 '18 at 11:57 AM

avatar image

TahaRizvi
88 3 5 12

avatar image Gos2002 Jan 25 '18 at 10:37 PM

this worked but its very confusing. I was able to edit him without those lines before.

avatar image TahaRizvi Jan 26 '18 at 02:19 AM

Hi Gos2002,

check selected only that is below 'all hierchy' button ... that wont show you lots of unwanted lines .. will only show what you have selected.

hope this will work.

kindly tick mark answer as complete, if this has solved your problem.

thanks

avatar image Gos2002 Jan 28 '18 at 05:04 PM

sorry I'm late. this didn't fix the problem. when I had the All Hierarchy checked it worked but when I clicked Selected only it wouldn't let me select the bones of a character. I'm not sure whats going on. I think I know whats going on. when I went into another project I found a physics tab on the top. when I went into this project, it's missing the physics. could this mean something?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey there can you send a video of the issue?

more ▼

answered Jan 22 '18 at 12:13 AM

avatar image

xlar8or
6k 163 129 305

avatar image xlar8or Jan 23 '18 at 12:41 PM

Have you tried restarting the engine? If yes then it might be some option you enabled or it's a bug.

avatar image xlar8or Jan 23 '18 at 01:00 PM

Please respond as a comment on my answer to keep things organized. If you import a new skeletal mesh and create a blend space for it, do you still have the issue? On the animation preview can you select the bones?

avatar image Gos2002 Jan 24 '18 at 01:19 AM

sorry. I didn't know how to reply like that at first. the video you saw was a brand new blueprint. I thought it was the blueprint at first as well. that was the first thing I thought. but when I deleted the old one and created a new one, that told me it was a bug or something that I have selected. I wouldn't know what I have selected though.

avatar image xlar8or Jan 24 '18 at 10:36 AM

Try creating a new project and if that doesn't work reinstall the engine making sure it deleted the cache folders. If that doesn't work you can submit a bug report, although it's going to be hard to replicate and thus hard to fix for the epic team.

avatar image Gos2002 Jan 24 '18 at 11:28 PM

the stuff works in a new project but not in mine. is there a way I can make it work again without restarting on my project?

avatar image xlar8or Jan 25 '18 at 11:16 AM

Did you try importing a new skeleton and creating a new blend space?

avatar image Gos2002 Jan 25 '18 at 04:01 PM

I created a new blend spave but it didnt work. I created one in a New project and it worksd there. Might be something I have selected.

avatar image Coollapse Nov 29 '18 at 08:55 PM

This helped me out so much.I know this is old,but still Just wanted to say thanks Taha Rizvi.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

i couldnt share the video so i uploaded it to youtube.

LINK: https://www.youtube.com/watch?v=HTBSKbHAZfM&feature=youtu.be

more ▼

answered Jan 22 '18 at 10:00 PM

avatar image

Gos2002
26 3 9 7

avatar image ThompsonN13 Jan 24 '18 at 11:51 PM

if your trying to move the skeleton you should be in the skeleton tab. look near the top right of your editor and you will see tabs that say skeleton, animation, mesh. click the skeleton one and you will be able to select bones

avatar image Gos2002 Jan 25 '18 at 04:02 PM

It doesn't work in any tab. I clicked on all of them and none of then could select rhe charactor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've restarted the engine and the computer. i thought it might be something i selected but i don't know what it could have been.

more ▼

answered Jan 23 '18 at 12:54 PM

avatar image

Gos2002
26 3 9 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question