x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Localize sound waves

Hello. I have three sets of sound waves: original files, localized ru (which are equal to original) and localized en. Localized sound waves are in L10N/en and L10N/ru folders. Localizations to Package are set to English (global) and Russian (Russia, also tried global), default culture is en. However, in packaged build I have only English sound. Also I have two sets of textures: original files and localized en (no ru localization). They work perfect after level reloading. Tried the same for sound waves (original and only one localization), but still it doesn't work. How can I make sound waves localization work? PS: please, don't suggest to use dialogue system. PS2: if there is no localized sound wave asset, it plays original file (that's convenient behaviour, I believe)

Product Version: UE 4.17
Tags:
more ▼

asked Jan 24 '18 at 11:36 AM in Packaging & Deployment

avatar image

KelbornKad
1 1 3

avatar image Jamie Dale STAFF Jan 24 '18 at 03:30 PM

Do you know when the sound waves are being loaded, and at what level they're kept alive? Does the issue also happen if you start the game using -culture=en set on the command line?

avatar image KelbornKad Jan 25 '18 at 01:22 PM

Do you know when the sound waves are being loaded, and at what level they're kept alive?

No idea. How can I track this? Only thing I can say now is that I call sounds not directly, but from data sheets.

Does the issue also happen if you start the game using -culture=en set on the command line?

I've made a shortcut and added -culture=en after .exe. Did I got you right? If so, it has no effect. Also =ru-RU doesn't start game with rus assets. New info: noticed that some sounds are localized and that's not because of assets' presence. I'll keep digging. Maybe I should have mentioned that I use that node for localization: ![alt text][1] [1]: /storage/temp/228384-снимок.png
снимок.png (61.6 kB)
(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question