x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to fix depth artifacts with Scene Capture Component 2D?

I'm trying to render a heightmap to a render texture using an orthographic Scene Capture Component 2D placed above the scene. However, unless I crank up the render target resolution up to 4K (which requires 600+MB of VRAM for 32-bit floats), I get terrible artifacting for the Scene Depth.

Consider this 1K heightmap texture (scaled down to visible range): alt text

Compared to this 4K (downsampled to 1K) heightmap: alt text

It's pretty clear to see the artifacts in the 1K version.

I really can't think of any logical reason for this.

Further notes that could be helpful are that I'm using Forward Rendering, because this is a VR project, and the orthographic width is 100000. The Scene Capture Component 2D is 5000-15000 unit above the landscape surface.

The bright part is where the landscape clips through the capture component, but those aren't important for my purposes.

Product Version: UE 4.18
Tags:
artifacts.png (161.7 kB)
correct.png (181.9 kB)
more ▼

asked Jan 24 '18 at 02:12 PM in Rendering

avatar image

novacrazy
11 1 3 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Are you confident, that landscape is rendering using the highest possible LOD into the depth capture ?

more ▼

answered Jan 24 '18 at 07:09 PM

avatar image

Deathrey
7.8k 130 30 292

avatar image novacrazy Jan 24 '18 at 07:15 PM

That would make sense, and was my first thought as well, but the Scene Capture Component 2D does not have any LOD settings except "Detail Mode", which has Low, Medium and High settings. None of those make a difference.

avatar image Deathrey Jan 24 '18 at 07:22 PM

If I were You, I would double check that, before moving on.

avatar image novacrazy Mar 18 '18 at 12:42 PM

Update: Epic has totally removed the Landscape LODDistance Factor in 4.19 with the new landscape revamp, so there is no longer any way to set it, and the Scene Capture Component 2D ignores all other LOD settings it seems.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Well, I did just solve it. I went back and looked at the landscape actor itself and set the LODDistance Factor on it from my capture blueprint, took the capture, and then set it back to 1.0

That seems silly that a calculation made in the camera can't be changed, and I have to override individual actors. If I had wanted to capture anything but the landscape, especially something dynamic, that would make it impossible or wildly impractical.

more ▼

answered Jan 24 '18 at 07:28 PM

avatar image

novacrazy
11 1 3 7

avatar image novacrazy Mar 18 '18 at 12:31 PM

Nevermind, this is broken again for no known reason. The orthographic camera simply ignores all LODDistance Factor changes now, and in 4.19 LODDistance Factor was removed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question