x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Recieving Compiling Error When Trying to Generate C++ Classes

Hi, recently I decided to teach myself how to use Unreal Engine. I already had Visual Studio 2017 installed. After installing the unreal editor I installed the unreal engine using the visual studio installer. I am able to generate c++ files for my unreal project however when in unreal if I attempt to create new C++ files linked with the project it gives me an error and the log reads

alt text

It then creates the file I specified however refuses to show said file in the Unreal Editor. Please help. I cannot add C++ components to objects until this is fixed.

Product Version: UE 4.18
Tags:
more ▼

asked Jan 25 '18 at 06:39 AM in Using UE4

avatar image

SyccInc.
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Double check that you have all the necessary VS components installed, not just UE4 support, but also C++ etc. If you already had VS installed you should rerun the configuration tool and add what may be missing.

Here is the official document you should refer to: https://docs.unrealengine.com/latest/INT/Programming/Development/VisualStudioSetup/

more ▼

answered Jan 25 '18 at 06:51 AM

avatar image

vr_marco
2.2k 10 6 12

avatar image SyccInc. Jan 25 '18 at 11:46 PM

I had everything needed installed. I tried again in a basic c++ project and it worked however when I tried to make a 2nd c++ class it failed and resulted in an error once again.

avatar image vr_marco Jan 27 '18 at 12:32 PM

Maybe it is a different one this time. A namespace conflict maybe?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question