x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FPlatformProcess::CreateProc with -log argument

Hello!

I use the "FPlatformProcess::CreateProc" to run another dedicated server with the -log argument, and I'm having problems.

If I run the dedicated server with the -log argument via a shortcut, then everything runs correctly. And if I run the same thing using the "FPlatformProcess::CreateProc", the dedicated server loads video adapter, which should not be. As a result, the server reports an error "Failed to choose a D3D11 Adapter" and stops working.

 void UPVFuncLibBP::LaunchArenaServer(UObject * WorldContextObject, FString Attributes)
 {
     FString ExecuterPath = FPaths::ProjectDir() + "Binaries/Win64/ServerManager.exe";
     UE_LOG(LogWindows, Log, TEXT("CreateProc %s %s"), *ExecuterPath, *Attributes);
 
     FPlatformProcess::CreateProc
     (
         *ExecuterPath,
         *Attributes,
         true,
         false,
         false,
         nullptr,
         0,
         nullptr,
         nullptr
     );
 }

And use this:

alt text

And result:

alt text

Tell me where to look for the answer. If there is a solution, I will be very glad to see. Many thanks!

Product Version: UE 4.18
Tags:
error.png (47.6 kB)
error3.png (11.9 kB)
more ▼

asked Jan 25 '18 at 08:43 AM in C++ Programming

avatar image

drkane
3 2 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The problem is solved. Instead of the server, the path was specified by the client, so the video adapter was loaded. We fixed the error, everything works fine.

more ▼

answered Jan 26 '18 at 08:47 AM

avatar image

drkane
3 2 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question