x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Keep losing the ability to add items to variables and arrays

EDIT: I'm able to reproduce this now - the items I was attempting to reference were in a folder in the asset tree that contained a "(" character. This was causing the issue!

I posted a bug report here but the problem turns out to be far more widespread in scope than I initially thought so I'm creating an updated report here.

Basically, after working in a project for a time, I lose the ability to add any of the following to an array or variable of that type as a default:

  • Materials

  • Material instances

  • Actors

This is a complete showstopper!

I can see the relevant item in the list, but when I pick it, nothing happens: alt text

I encountered the error first in the Code-based FPS project when creating a custom struct. I was unable to solve the issue, and after testing to see if it was working properly in a clean project, I migrated my blueprints to the new project and the problem persisted.

Not knowing what else to do, I completely rebuilt my project from the ground up and low and behold the bug has reappeared. I can't move forward, and I'm at a complete loss as to what to try next. The issue persists when I shut down and reopen the project and I have no idea how to fix it.

Product Version: Not Selected
Tags:
example.jpg (180.9 kB)
more ▼

asked Jul 26 '14 at 11:06 PM in Bug Reports

avatar image

Hyperloop
1.2k 57 67 97

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey, Hyperloop!

Thanks a lot for finding this bug for us. I'm able to reproduce it here at the office, which means I can now report the bug and we'll get to work fixing it. I really appreciate that after running into the bug, you managed to find the cause and edit your post to include it. Great work!

Thanks again,

Jonathan

more ▼

answered Jul 28 '14 at 05:16 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question