x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Missing "Attenuation overrides" for Steam Audio

Steam Audio guide says that you need at least 4.19 to get it work, and I have 4.19 Preview 2 from Epic Launcher. Guide here says to go to Attenuation overrides under Attenuation tab, but, that Attenuation overrides missing for me.

Maybe I missing something? Or guide itself outdated already?

Maybe all of this applied when I did this?

Product Version: UE 4.19 Preview
Tags:
more ▼

asked Jan 29 '18 at 12:33 PM in Using UE4

avatar image

Bed Inc.
8 3 6 8

avatar image JimmothySanchez Feb 01 '18 at 04:29 AM

I'm having this same issue. I've tried the answer below but most of the steps require setting checkboxes that don't exist on my asset. The Shift+6 step didn't do anything on my machine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

To all who are too have these differences as me:

Go to Edit > Project Settings... > Scroll all the way down to Plugins section > Click Steam Audio > In Indirect Spatialization Method set HRTF > Press Shift+6 > In showed up menu click Add All > Click on any sound effect (not in Content Browser) > Under Attenuation tab uncheck Override Attenuation (check only in special cases) and create asset for Attenuation Settings > Open that > Under Attenuation Spatialization tab in Spatialization Method set Binaural > Under Attenuation Air Absorption tab check Enable Air Absorption > Under Attenuation Occlusion check Enable Occlusion > Under Attenuation Plugin Settings in Plugin Settings create assets for Spatialization and Occlusion (click on +) > In created asset for Spatialization in Spatialization Method set HRTF, and in HRTF Interpolation Method set Biliniar > In created asset for Occlusion in Direct Occlusion Mode set Direct Occlusion, Frequency-Dependent Transmission > In Direct Occlusion Method set Partial.

After all of this stuff hear sounds will be much better. Remember - this is basic Steam Audio setup on your game. You can read full guide and watch videos on youtube to tune every single detail.

And don't forget to set Attenuation Settings in every sound to your asset.

more ▼

answered Jan 29 '18 at 01:15 PM

avatar image

Bed Inc.
8 3 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I found the solution! As mentioned in the documentation (https://github.com/ValveSoftware/steam-audio/blob/master/unreal/doc/phonon_unreal.md):

Next, you must modify the command-line arguments used when launching the editor using the shortcut:

  1. Right-click the shortcut to the Unreal editor and click Properties.

  2. In the Shortcut tab, under Target, add -audiomixer at the end of the command line. (..." -audiomixer)

  3. Click OK.

https://steamcommunity.com/app/596420/discussions/0/1290691937731279814/

more ▼

answered Mar 16 '18 at 05:33 PM

avatar image

SiLiUSD
40 1 3 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question