x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Shadow detail distance too low?

I hate to be that guy asking about shadow issues but i feel like i have misconfigured something and ive just spent hours trying to fix this, My shadows seem courpted / or blotch but render good really close to the camera. Im having UE4 Generate the Lightmap.

alt text

alt text

alt text

Product Version: UE 4.18
Tags:
help3.jpg (298.3 kB)
help2.jpg (202.7 kB)
help4.jpg (578.1 kB)
more ▼

asked Jan 30 '18 at 08:28 AM in Rendering

avatar image

KTR19
48 1 2 7

avatar image KTR19 Jan 30 '18 at 10:44 PM

Bump, I changed some settings with the Cascade Shadow options on my main light source after rebuilding the lighting. Issue is still there on many of my mesh's. I'm beginning to think this is my light map resolution on my Mesh's or that my Shadow map is too small.

I do not think this is a case of improper Light map UV.

One of the things I learned was that my Grid in my UV texture editor in Maya was way off causing Artifacts previously but since then I have fixed this.

Has anyone experienced this or have a workaround? I'm sure its something as simple as a check box or a wrong value.

avatar image KTR19 Jan 30 '18 at 10:45 PM

Many of my Models and BSP Brushes are Blotchy on the shadows

avatar image Makigirl Jan 30 '18 at 11:00 PM

Hi!

Do you mean the two little rectangle lights after the bake /that it's not the correct shape?/? ...or the second image where the lines re not straight?

avatar image KTR19 Jan 30 '18 at 11:49 PM

not the correct shape, the Shadow is throwing the triangle bits. It should be clean lined like the second image. I disabled Cascade Shadow's so its just blotchy and incorrect shape.

I was following this guide here https://wiki.unrealengine.com/LightingTroubleshootingGuide#Static_Lighting

I'm going to try Upping up my Shadow res / Light map res on my model, Light and terrain.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Yes! The lightmap resolution is too low on the receiver side (floor)! You will get the correct light/shadow shape if it'll have enough resolution! ...BSPs used to work the opposite way: you had to lower the amount...

more ▼

answered Jan 31 '18 at 12:01 AM

avatar image

Makigirl
1.1k 3 4 8

avatar image KTR19 Jan 31 '18 at 01:21 AM

I'm not home right now, I will have to check out the Light map Resolution and scale it higher to see if this is my issue I am at work Eager to Fix this!

As far as the BSP I believe its still true Lower = Higher Quality. But not for Models. I mainly use the BSP for Blocking out General shapes till I can mesh in the level.

avatar image KTR19 Jan 31 '18 at 06:13 AM

I can confirm this was my issue, I instead had set the Min Light map resolution instead of the actual light map resolution! alt text

I'm currently running around fixing all my assets Thank you for Guiding me in there!

help2.jpg (342.4 kB)
avatar image Makigirl Jan 31 '18 at 03:38 PM

Good luck! :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question