x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Packaged project won't start on Mac

Hello! I have a project I am making for a Windows platform on a Windows machine and everything works fine there, but recently I decided to build that project for Mac as well. So I transferred the project on to my Mac. In the editor, it all worked fine, but after I packaged the project it just won't start. When I start it, the process appears in the taskbar, but no matter how long you wait, the game window doesn't open. No crashes, errors or warnings, though. Firstly I thought that my plugins could do something wrong (Victory plugin and my custom one), so I disabled them, but nothing worked. I've tried resetting the project settings, switching the starting map, resetting all the plugins, but it seems like the problem isn't there. Not only I tried one type of build, but all of them (Development, Shipping, For Distribution). I tried building an empty project, as well as an empty project with just my plugins, and they both worked fine. I tried to search for the game's logs, but I couldn't find them, nor the logs from the editor or the build tool (I searched through all the locations they could possibly be, according to UE4 Documentation and some answers on the Answer Hub). Lastly, I've tried starting that build from 3 Mac computer with all the same results. I am going to try to disassemble my project piece by piece now, and would appreciate any help!

Product Version: UE 4.18
Tags:
more ▼

asked Feb 02 '18 at 03:36 PM in Packaging & Deployment

avatar image

Hnomer
63 3 6 9

avatar image 0x414e54 STAFF Feb 02 '18 at 03:57 PM

If you start the game from the terminal you might be able to see some more useful information about why it is not starting correctly.

Assuming your project was called "MyProject" you can do this by going to navigating through the folders MyProject/Binaries/Mac/ and right clicking on MyProject and then "Show Package Contents". Then navigate through Contents/MacOS and right click on MyProject and "Open With->Terminal".

Or you can run ./MyProject/Binaries/Mac/MyProject.app/Contents/MacOS/MyProject if you are familiar with using the terminal directly.

avatar image Hnomer Feb 02 '18 at 04:08 PM

Oh, yes! I discovered that right before I read your message! :) I have a bunch of build iterations saved. So the first iteration (the point at which this problem was discovered) says "exit;" right after it starts and then nothing else, but the process remains. The last iteration where I tried to reset all the settings to default, suddenly started working! Iterations in between get stuck on "Initializing movie player...". I guess I'll start resetting the settings to the master project state and try to figure out what caused the problem. Thanks for the answer, anyway!

PS Forgot to mention that the first iteration was For Distribution, so no wonder why there were no logs.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The problem is completely solved! I guess there is no borderless mode on Mac OS, so remember to DISABLE "Use borderless window" option in the project settings before building for Mac!

P.S. This cost me 5 days to solve...

more ▼

answered Feb 02 '18 at 05:17 PM

avatar image

Hnomer
63 3 6 9

avatar image cgd Jul 06 '18 at 04:44 PM

You are wonderful and spare us tons of time!!! <3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question