x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Bad Name Index Error on Packing

Whenever I try to pack my game it keeps having the error:

"LogInit: Display: LogLinker: Error: Bad Name index -1/96"

"LogInit: Display: LogLinker: Error: Bad Name index -1/108"

Please someone help me, I've spent so much time in this project, I already have searched the error in the internet but none of the ones I've found is similliar to me nor have answers.

I've fixed the log here.

Product Version: UE 4.18
Tags:
uat-log.txt (846.8 kB)
more ▼

asked Feb 02 '18 at 05:19 PM in Packaging & Deployment

avatar image

LucasVix
1 1 1 1

avatar image davidwkimber Jun 22 '18 at 06:31 AM

I'm going through a similar issue, and haven't found a fix for mine yet. But for yours, at least the first error you're getting, I found that setting the Default Touch Interface in your Project Settings > Input menu to 'none' gets rid of that error.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Check the lines around where the errors first appear in your logs. Those assets might be the culprit.

Looking at the log I think you should check the following: - you're missing the crouch action used in the Ue4ASP_Character. Add the binding and see if an error disappears. - open the WaveMode asset and check if all is good. Save asset even if it look ok.

I had this same problem a minute ago and fixed it by checking my animations, skeletons and physics assets for errors.

Hope it helps.

more ▼

answered Feb 13 '18 at 07:38 PM

avatar image

Poolbeer
26 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

For anyone show still has this issue. You can find the asset causing this by building the engine from source and adding breakpoints here and here. Loading the project then already triggers the breakpoints. In the stacktrace you can then find the call to UObject::Serialize(FArchive & Ar) which will reveal the name of the asset that is causing the issue: alt text In my case BT_Unit_Default. Which is a Behavior tree. I made a new Behavior tree and copied all the nodes into it and that fixed the issue. I guess it was some internal error in the behavior tree.

more ▼

answered Aug 25 '18 at 05:06 AM

avatar image

erikdubbelboer
361 3 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Same issue, I found the problem by changing the "verbosity" :

Change Cooker Progress Display Mode to Names and Remaining Packages in

Project Settings / Engine - Cooker

It'll display the progression file by file, at least you'll know were to search the issue (resaving/compiling file, ...)

more ▼

answered Oct 10 '18 at 04:10 PM

avatar image

LaZeKler
21 1 4

avatar image Kokuyouseki Feb 03 '19 at 01:37 PM

I cannot find this option there - or anywhere for that matter. DId they remove it?

avatar image LaZeKler Feb 04 '19 at 02:55 PM

I have still the option in 4.21.2

alt text

settings.jpg (75.1 kB)
avatar image Kokuyouseki Feb 04 '19 at 04:46 PM

Mine is 4.19.2 - might be the issue, I guess I shall try updating. In the meantime I did find the problematic asset, my main model - renamed it at the beginning, showed no signs of problems but I guess it was allergic to that after all. Now it's fixed.

Moved the assets in small groups to a new project and checked packaging for the error - and when the model was copied over: boom. Easy - just timeconsuming as hell.

alt text

ue4-cooker.jpg (160.0 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question