x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Suddenly Unable to Commit to git

I have been using a local git repository to manage my project successfully over a dozen commits. However, a few days ago I tried to make a commit and received an error, saying that my project was initialized. I checked and the .git is still there. The repo still shows up in github desktop. But for some reason Unreal won't connect and initialization isn't an option, because there already is a .git. Anyone have any idea?

Product Version: UE 4.14
Tags:
more ▼

asked Feb 04 '18 at 01:54 AM in Everything Else

avatar image

fnor
42 3 1 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, I am the author of the Git plugin, can you check the logs in Saved/Logs/ and see what the exact error is?

more ▼

answered Feb 04 '18 at 06:40 AM

avatar image

SRombauts
1k 20 17 96

avatar image fnor Feb 04 '18 at 02:34 PM

Thanks for the reply. I put together the output that included source control from the log of day it stopped working and the most recent attempt to commit. If you need more let me know, the logs are big.

https://pastebin.com/Lwt9WMj9

avatar image SRombauts Feb 04 '18 at 03:05 PM

Sorry, I see nothing interesting in the logs : could you start a new session of the Editor, try anything like Submit to Source Control, and capture all the logs up to this moment (that is, don't close the editor do you will not add all the shutdown logs)

Edit: also it could be something related to an update of Github Desktop that is no more recognized by Unreal Engine

avatar image fnor Feb 04 '18 at 03:42 PM

Full log from a fresh session:

https://pastebin.com/SGeJt56R

avatar image SRombauts Feb 04 '18 at 04:10 PM

Okay, still no luck, no more information...

So on my mind there are two options :

  1. Either you install Git for Windows with the hope that the UE4.14 plugin catch it

  2. Or you try to upgrade the plugin, by installing my standalone plugin V2.5 in your project's Plugins folder, which should at least give you some more information in logs

avatar image fnor Mar 03 '18 at 03:59 AM

Using the executable from git for windows did the trick. I am still able to use github desktop to manage pushes to github, so the only issue was re-aiming the plugin to a different binary.

Thanks for your help.

avatar image fnor Feb 04 '18 at 05:21 PM

Grabbed the current version of the plugin, put it in my project folder and tried to launch. Unreal said it couldn't build, so I went to VS to rebuild, got this:

https://pastebin.com/hML3UceP

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question