x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why am I seeing NavMesh issues in 4.3?

Here are several issues our team has run into while using Navmesh in version 4.3:

  • Navmesh bounds volume will not update when rotated

  • Navmesh won't work on meshes that are scaled

  • Navmesh Preview won't update

Product Version: Not Selected
Tags:
more ▼

asked Jul 28 '14 at 03:24 AM in Bug Reports

avatar image

renderman09
162 11 12 24

avatar image Ben Halliday STAFF Jul 29 '14 at 05:11 PM

Hey renderman09,

  1. The Nav Mesh should update when you rotate the NavMeshBoundsVolume, but it looks like it isn't creating angles consistent with a rotated volume; instead, it makes a square based on the corners of the volume. Is that what you're seeing, or is there something else going on? I'm going to check with the developers to see whether this is intentional.

  2. I have not had any trouble with scaled meshes, though scaled meshes are known to cause other problems and it's generally better practice to make sure they are roughly the correct scale before importing them. A couple things to check: In Project Settings > Navigation Mesh, do you have Rebuild at Runtime enabled? In Project Settings > Navigation System, do you have Build Navigation at Runtime enabled, and the Dirty Areas Update Freq set to 60.0 or so?

  3. When you say Navigation Preview, are you referring to the green field in the Viewport? If so, it should be updating if you have your settings as mentioned above.

If you have more specific details about what's not working and under what circumstances, I can help investigate the issues you're experiencing. Thanks!

avatar image renderman09 Jul 30 '14 at 01:21 AM
  • It seems that when the volume is rotated, it snaps back to its original rotation.

  • Yes we are still getting used to the import scale settings. I will check on the Rebuild at Runtime and the Dirty Areas Update.

  • Yeah the green field. It used to update with the last version. Doesn't seem to work consistently in this version.

We found an option for converting collision boxes into convex collision under the mesh properties. This may have fixed the Navmesh not recognizing the mesh, but some of the other problems still exist.

avatar image Ben Halliday STAFF Jul 30 '14 at 07:22 PM
  1. I'm not seeing that behavior. I'll keep messing around with it to see if there's a setting I'm missing. If you wouldn't mind, can you create a new project from the Top-Down template, find the NavMeshBoundsVolume1 in the Scene Outliner, and rotate it? I'm curious if this is specific to one project for you or if it happens in each project. Thanks!

  2. Please let me know what you find with those settings.

  3. Same as above... I suspect adjusting the settings will fix this issue for you.

Thanks! Let me know what happens.

avatar image Alan Webster Jul 31 '14 at 09:18 AM

after updating to 4.3 the navigation was woking fine for me but preview window always stated that navmesh needs to be rebuilt. but now since I've moved some static meshes in the level I've got the same problem stated above and will navigation not work at all.

avatar image Ben Halliday STAFF Jul 31 '14 at 06:27 PM

Hey Alan,

I have the same questions for you as I do for renderman09. Please let me know if you get the chance!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I've found a solution for this that fixed it for me. in my project in 4.2 i had disabled (unchecked) "update navigation automatically" in the Editor Preferences as it was taking to long to place meshes. since i updated to the project 4.3 i could not enable it as the Editor Preferences in the menu had disappeared. i work on a mac and found the Editor Preferences has moved to the Apple tool bar. so enabling "update navigation automatically" has got me working again although you'd think Build at runtime settings should have worked anyway. hope this helps, let me know.

more ▼

answered Jul 31 '14 at 06:26 PM

avatar image

Alan Webster
860 50 34 81

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Rebuild navmesh.

more ▼

answered Jul 28 '14 at 07:35 AM

avatar image

AntonioModer
198 16 21 25

avatar image renderman09 Jul 28 '14 at 10:41 PM

Yeah we tried that numerous times with no luck.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question