x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

What causes error "pending connexion failed"?

Hello AnswerHub people, and first of all thank you for your dedication. It really helps newcomers like me understand the engine better.

Anyway!

I've been following the official "Blueprint multiplayer" tutorial - https://www.youtube.com/watch?v=abmzWUWxy1U -

Everything works fine when i play in editor, and my 3 to 11 characters can join the same lobby map just fine.

When i play in standalone on 2 different computers however, there is a problem:

I cannot join session.

alt te![alt text It finds the right session (or so it seems)

https://i.gyazo.com/968559d795e3802385380dbea3deed41.png tries to load, and eventually fails, flashing a NetworkError: Pending Connection Failure, before going back to main menu

https://i.gyazo.com/68f77bf60007d87bd5b696455ed101e5.png When I try to join the session again it just prints failed to join.

https://i.gyazo.com/a302b73dc70b920ea1fc2caf7cae5186.png My GameInstance Create/Join/Destroy nodes

alt text

My search/refresh session node (i have a call to "join server" in the event graph as well)

Also: My DefaultEngine.ini is set,

Steam is up and running on both computers, and the steam plugin is added to the project,

I'm NOT using Gamemodebase class but Gamemode class,

Seamless Travel is on,

When i open the lobby map, listen is on...

To sum it up, I guess my question is quite simple:

What else do i need to check? What can cause Pending Connexion failed?

Thanks in advance!

Product Version: UE 4.18
Tags:
more ▼

asked Feb 07 '18 at 02:46 PM in Blueprint Scripting

avatar image

Jondoes
6 1 2

avatar image Jondoes Feb 08 '18 at 04:28 PM

Daily bump. I really need this to work guys :/

avatar image Jondoes Feb 10 '18 at 04:21 PM

bumpalicious. Anyone?

avatar image superfreakspy Mar 27 '19 at 05:48 AM

I'm having this exact problem with my little project game as well. I have Steam set up correctly in the DefaultEngine.ini, everything seems to be hooked up correctly (I'm doing all of this in the menus and putting the functionality in a game-instance, I'm calling it all correctly and everything is checking out that way) and it gets to where it says I've joined the server, and then bam puts me back in my main menu still technically connected to the other server, but I've set it up to catch any possible errors and it's catching the "Pending Connection Failure" error even though everything seems to be set up correctly.

I've gone back and forth checking my engine.ini, checking my server hosting, finding, and joining functions and making sure they're all doing what they're supposed to (they are) and it seems that I keep getting this error even though I'm able to successfully broadcast and find servers.

If the original poster happened to find an answer, posting it here would be greatly appreciated, but if anyone else has an answer that would be greatly appreciated too.

I think it should also be noted that I have done this before on a separate project, and it had worked just fine no problem; however, between that project and this one, there's really no differences in how I handled the functionality and UI. Everything is hooked up the same way (albeit a little more efficiently this time), and everything should be working, but just isn't. Any kind of response would be greatly appreciated.

avatar image Jondoes Mar 27 '19 at 05:13 PM

Hey, I never ended up finding a solution to this.

To be perfectly honest i dropped the project for 2 main reasons:

  • My lack of knowledge regarding replication

  • The tutorial series i followed was rushed and ends without proper steam testing. Since then, i try to make sure of who at Epic is doing the tutorial i want to watch, as well as read the comments about said tutorial.

Sorry i couldn't help more. Hope you find a solution.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I found the solution to my problem; however, the actual cause behind my pending connection failure was a pretty specific case and there's almost no way that anyone else was suffering from the exact same reason I was, but long story short I was using an engine version built from source code, and had altered the source code in order to run a dedicated server and make it work customizably. Well, what ended up happening is when I started a new project, the changed source code carried over and was incompatible with the way I was trying to set up networking in this new project.

The actual specific problem I was encountering was that my engine was set up in a way that was making the hosted port be 0, which just won't work. After I deleted the source code version of the engine and downloaded the newest (as of writing this), engine version, everything started working as expected and I was no longer receiving the error and connections were going smoothly.

If you are encountering this same problem, I recommend checking your log files to see what exactly is happening when you're trying to set up and join a network. Generally it will give you an idea of where you're going wrong or what is or isn't happening that is breaking it.

So to sum up: Check the logs. The problem is probably very specific to you, and only your logs can identify the problem.

more ▼

answered Apr 02 '19 at 02:16 AM

avatar image

superfreakspy
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question