x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My project won't open. It gets stuck at 71%

Hi, my project was fine yesterday, but today when I tried to open it, the launcher would stall at 71%.

I tried deleting the Saved, Intermediate and Binaries folders, even the Config, but it still does the same thing.

I tried to Verify my Unreal Editor's version but it got stuck at 98%, so I uninstalled it and reinstalled. Still does the same thing.

I tried reverting my repo but it seems to do the same thing anyhow, so the problem must be in my launcher.

I don't know what else to do and need help absolutely as I am supposed to package this project tomorrow!!

Anyone has had this issue and knows a way of making it work again?

Product Version: UE 4.18
Tags:
more ▼

asked Feb 07 '18 at 09:39 PM in Using UE4

avatar image

FredPoissant
60 4 10 17

avatar image FredPoissant Feb 07 '18 at 09:43 PM

Note That I tried opening a backup of it and it does the same.

When the freezing occurs, The Editor takes 0% CPU.

avatar image Cabewz Feb 07 '18 at 10:10 PM

Are you able to create new projects or load other projects?

avatar image wickerman123 Feb 08 '18 at 09:29 AM

If you are able to create new projects that don't have the issue, you could try migrating all the assets into a new project failing the above methods.

avatar image FredPoissant Feb 08 '18 at 09:31 PM

That is what I did. I managed to get an older git to work and copied and pasted what I could from a backup on a second hard drive.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Seems weird. Maybe try making a new template project to see if that loads OK.

And there should be a log of what it got done before the freeze, maybe there's relevant info in there.

Ultimately, you could build it in "Debug Editor" (github engine only) and when it gets stuck you can break execution to see where it's getting stuck in a loop (or locking the main thread). If you try this and get results but can't interpret them, post what you find. Maybe we can help you figure it out.

more ▼

answered Feb 07 '18 at 09:58 PM

avatar image

Jin_VE
4.5k 32 79 42

avatar image FredPoissant Feb 08 '18 at 09:36 PM

Thanks for the advice. Actually it was my BP_Character that made it freeze. I did not manage to get a log of what happened because it was not completely crashing (or maybe I just don't know how to get it without a hard crash), but by downloading an older git and copy pasting what I could from a backup, I managed to get most of what I had lost. Only took me 2 days to get everything back instead of two months!

avatar image Jin_VE Feb 08 '18 at 09:40 PM

Just in time! Congrats and good luck in the future.

avatar image FredPoissant Feb 10 '18 at 03:33 PM

Would you happen to have a link to the github engine? When I try to get it from the launcher it only opens the github main page and i can't find it.

avatar image Jin_VE Feb 10 '18 at 06:27 PM

You need more than a link but you can find it and everything else you need here.

avatar image FredPoissant Feb 14 '18 at 09:30 PM

I could not build it in debug editor because my .sln file makes the github editor crash in visual studio (not responding), it also seems to stop at around 71%. I tried loading it in visual studio 2017 and building it from there, the error it gives me is: unable to compile. Try building from source manually.

avatar image FredPoissant Feb 14 '18 at 09:32 PM

I also get a comment on the .dll file that seems to be the wrong one. It does that when I build it in visual studio and also when I try to package the project.

avatar image Jin_VE Feb 14 '18 at 09:54 PM

Make a copy of your project (don't include intermediate directories), right-click on the uproject file and select "Switch Unreal Engine version...". Pick the version of the github engine and it will regenerate project files. Try building that in VS.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Sounds like you have a blueprint circular dependency, which is super fun because UE4 doesn't tell you that its a thing until its too late to know why or where.

We've had this countless times where the editor seems to get stuck at either 71 or 72% while loading, only way to fix is to revert work you've done recently until it loads again. Thats if you're using source control anyway, if not and this is the issue then your next best option is to just delete assets until it works to find the offending asset and remake it.

more ▼

answered Feb 14 '18 at 11:52 PM

avatar image

GotSomePills
69 5 8 12

avatar image FredPoissant Feb 14 '18 at 11:59 PM

Oh!! This i.e. or for sure ne cause or I delete my BP_Character it opens, my last update was health, stamina and weapon heat regen, so I'll simply delete them one by one to see which one is the problem and find a way to script it differently. Thanks for the help!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question