x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Aim Offset Yaw Issue

I have an aim offset with poses that require both pitch and yaw input. The pitch works perfectly fine, but when I hit the limit for yaw (-90,90) it snaps back to the beginning, if that makes sense. For example, My "middle" pose is at pitch 0, yaw 0. My "right" pose is at pitch 0, yaw 90. When the yaw is at 90 and I keep moving my mouse to the right, it "snaps" back to yaw 0 and will continue to loop as long as I keep moving the mouse to the right. It's as though the clamp angles are not working fully. Any insight is appreciated.

Product Version: UE 4.18
Tags:
more ▼

asked Feb 09 '18 at 07:27 AM in Using UE4

avatar image

oACE3o
20 2 3 9

avatar image oACE3o Feb 12 '18 at 03:34 AM

This is being done with a custom mesh/armature from blender. I just replicated this with the UE4 Mannequin and I got the same result, so it must be an engine bug of some sort.

avatar image oACE3o Feb 14 '18 at 03:55 AM

I also just replicated this exact scenario in 4.17 with the Mannequin and got the same result.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question