Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Lightmass swarm not working

My swarm agents appear to be set up properly, but the remote agents never actually start computing lightmaps.

I get errors spammed to the local agent log:

 [PushChannel] Pushing the channel has failed!

I've tried using wired connections to the same router as well as wifi connections, it doesn't seem to make a difference. The graph shows the remote agent in a 'connecting' state for the duration. The remote agent's log says:

 [Connect] Remote agent connection confirmed: CHRIS-DEV-PC
 [Job] Accepted job 57109.. etc

Here's the local agent screens: alt text alt text

Product Version: Not Selected
capture.jpg (132.2 kB)
capture2.jpg (192.4 kB)
more ▼

asked Jul 28 '14 at 04:03 PM in Rendering

avatar image

497 25 16 33

avatar image Lovecraft_K ♦♦ STAFF Jul 28 '14 at 06:48 PM

Hi cgrebeld -

Thank you for your report. I will begin investigation into this issue as soon as possible. If possible could you please go to your CPU that is running the Swarm Coordinator and another just running the Swarm Agent and let me see the settings panel for each.

Thank You

Eric Ketchum

avatar image cgrebeld Jul 28 '14 at 07:32 PM

Here's the coordinator machine: alt text

avatar image cgrebeld Jul 28 '14 at 07:33 PM

Here's the agent-only machine: alt text

capture4.jpg (76.6 kB)
avatar image Lovecraft_K ♦♦ STAFF Jul 28 '14 at 07:45 PM

Hi cgrebeld -

Try changing the Agent GroupName and AllowedRemoteAgentGroupNames to anything else and copy to both and try to rebuild and see if that will allow a better share of space.

Also it is best to use the CPU that is least powerful to be the Coordinator but start the build from one of the agents this will allow the coordinator to only function as the coordinator and distribute the processing.

Thank You and Let me know if either of those solutions work for you -

Eric Ketchum

avatar image cgrebeld Jul 28 '14 at 08:49 PM

Thanks for the reply. I tried both suggestions, but they seemed to have no effect. The job looks like it's being distributed, but the remote agents never start calculation, and the "Pushing the channel has failed" error message is being spammed to the local agent.

avatar image Lovecraft_K ♦♦ STAFF Jul 28 '14 at 08:59 PM

Hey cgrebeld -

Instead of entering the name of your CPU in CoordinatorRemoteHost, look up and type in the IP address, it will probably be some sort of local IP address like

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, I got it working by following one of the answers here:


I had to copy the files from the 7z file from dropbox into my local installs! I guess the missing files is due to a bug in your distribution packaging process.

I'm still on 4.2.1, so I'll let you know if 4.3 requires the same hacks.

more ▼

answered Jul 28 '14 at 09:30 PM

avatar image

497 25 16 33

avatar image echoform Aug 04 '14 at 06:22 PM

hello, i tried with 4.3.1 and followed all the steps (including adding the dropbox files and the patch files), but it's not working. would like confirmation from epic that swarm is indeed working at least on their end.

i am on a gigabit LAN and have been able ping the coordinator and agents successfully. but when i start the build process, only the coordinator machine is processing the build and all the agents remain idle.

avatar image cgrebeld Aug 04 '14 at 06:44 PM

Hi, I'm not Epic - but I can confirm that swarm works with 4.3.1 on our machines, once those binaries are added as described in the other bug: 3 x AutoReporter.* files go into DotNET and the .pdb file goes into Win64.

avatar image echoform Aug 04 '14 at 07:47 PM

thanks for the reply. good to know it's working. i read another thread about different .net install causing issues. will investigate that route and hope for the best.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question