x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Changing Particle System Rate with Blueprints?

For some strange reason, I can't change the rate of my particle system at runtime. What's even more strange is that it works when I do it on Begin Play. But it doesn't work when I try to change it at any other time.

I have an asset, and i want the Particle system to have a higher rate the lower the health gets. The logic works fine, but it refuses to change the rate.

I can have it set the Particle Rate on begin play, but if I try to execute it at any other time it fails.

Any advice?

alt text

Product Version: UE 4.16
Tags:
particle1.png (47.1 kB)
particles2.png (25.5 kB)
more ▼

asked Feb 10 '18 at 04:59 PM in Blueprint Scripting

avatar image

Raxs_Slayer
171 8 17 20

avatar image Exonfluxx Feb 10 '18 at 07:23 PM

I have a game with the same issue. I searched all over trying to see what i was doing wrong and everything was telling me i was doing it right. However it still would not change the spawn rate for me. I left off with a post where someone said that it only works with GPU particles which would not work for what I needed so I just made 5 emitters with different rates and just swapped out one for the other .. would be cool if it worked.

Sorry I couldn't Be of more help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I might of actually figured it out. As it turns out, I can change the setting during run-time. I reckon this is a bug, but if I start the game when the Rate is set to 0, or set it to 0 during the game, It wont let me change it to anything else. Which makes no sense. I can set it to 1, which makes it pretty much off, and then change it to 300 or whatever I like. But the moment I set it to 0, I can't adjust it after that, it's almost as if it kills the particle system entirely when it is set to 0.

more ▼

answered Feb 13 '18 at 12:26 PM

avatar image

Raxs_Slayer
171 8 17 20

avatar image Exonfluxx Feb 13 '18 at 01:09 PM

Really,

I will defiantly have to try that. I was fighting with this for days. I had a glob made with particular effects and I would set it to 0 and it would fill up based on an amount later on and it would never adjust. Did not even think to set it to 1 and go from there. Thanks for this information.

Might want to add it to UE4 bug list and let them know this and see what they say.

Good Job.

avatar image Raxs_Slayer Feb 13 '18 at 03:18 PM

Cool. Thanks. let me know how it goes (:

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question