x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Widget text is a different color in game than in engine

I have a widget blueprint to show a main menu. Everything was fine until I recently added a new button in the menu to enable cheat codes. The problem started when I noticed when I changed the color of the button text, it would go back to white after I hit the compile button in the BP. I closed the BP and reopened it and that fixed that issue. However now, no matter what I have the color of the button text set to, it shows the correct color in the editor but as soon as I run the game the button text is white. I have tried clearing the Binaries folder and restarted the engine, cleared the Binaries and Intermediate folders and restarted the engine and I have cleared both Binaries and Intermediate folders and restarted my computer and the problem persists. The problem exists when I run the game from the editor, debug and shipping builds.

Here are the buttons from in the editor alt text

And here are the buttons when I run the game. It doesnt matter if I run it in PIE, Standalone Game, release build or debug build the text is white. alt text

Any ideas on how I can fix this issue?

Product Version: UE 4.18
Tags:
buttonsineditor.png (316.9 kB)
buttonsingame.png (135.8 kB)
more ▼

asked Feb 10 '18 at 06:25 PM in Blueprint Scripting

avatar image

jman2015
36 9 16 17

avatar image jman2015 Feb 10 '18 at 09:37 PM

I ended up removing cheat codes as an unrelated issue made it no longer desirable so this isn't an issue anymore. However if anyone still has any ideas on what might have caused it I'd like to hear.

avatar image Dune Feb 12 '18 at 02:56 PM

Was the button highlighted in any way and was the highlight text colour set to white? Maybe from some controller style input as first button being highlighted automatically perhaps?

avatar image jman2015 Feb 12 '18 at 03:55 PM

The buttons change alpha only when hovered not the actual color. And it wasn't highlighted when I took the screenshot.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question