Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Event Begin Play of Level Blueprint fires twice

While working on my project a bug appeared that I eventually traced to the Level Blueprint's 'Event Begin Play', which had started firing twice for no reason. I began removing things from the project to try and figure out where the problem was, but I removed absolutely everything - all assets, actors, variables and blueprints - leaving only a blank project with this code:

alt text

This had no effect:

alt text

I tried importing the project into the 4.19 preview version, but it still behaves the same. You can download the project files here: Project Files (813kb)

Product Version: UE 4.18
riftris142-bp.png (20.0 kB)
riftris142.zip (832.7 kB)
more ▼

asked Feb 10 '18 at 08:18 PM in Bug Reports

avatar image

11 1 2 7

avatar image Light_Shock Feb 11 '18 at 11:00 AM

Are you using steaming or level instances or is this behaviour in the editor with the just the level?

avatar image CrowPath Feb 13 '18 at 10:15 AM

No streaming or level instances. As stated above, everything in project was removed except for the code shown above. The project files are available to download.

avatar image Sean L ♦♦ STAFF Feb 12 '18 at 12:40 PM


We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.



avatar image Tredigraph Oct 31 '18 at 04:47 PM

same here, any news?

avatar image The_Reaper77_ 5 days ago

4.21 the same

(comments are locked)
10|2000 characters needed characters left

8 answers: sort voted first

Hello Duncan,

I got your bug submission, replying here for visibility.

This is... maddening. I'm not seeing this in a new map, so my best guess is that this is a result of the map being created in a previous engine version. (Riftris map is 31kB, and a new blank map with same nodes is 26kB) I moved your map into a blank project and it's still printing twice.

Best workaround would be to migrate assets/nodes/macros to a newly created map.

Thank you for all your work and sharing with Riftris!

more ▼

answered Feb 13 '18 at 06:03 PM

avatar image

Alex O ♦♦ STAFF
2.5k 3 8 9

avatar image CrowPath Feb 13 '18 at 07:39 PM

Hi Alex,

I figured this would end up being be the case. Since only the map itself was left, it suggested something rather fundamental was off. Mind you, I had been upgrading the same project across most new engine versions since 4.5.

Nothing left but to port it over then. Cheers for having a look anyway.

avatar image CrowPath Feb 23 '18 at 03:34 PM

So I recreated everything in a new map and it was working fine for a week until I started adding stuff to the Event Begin Play again. Now it's firing three times!

alt text

I'm beginning to think the Delay node is the thing that's causing irreparable damage to the map file.

alt text

3 Hellos project files

riftris142.zip (1.9 MB)
hello.png (10.4 kB)
eventbeginplay.png (116.4 kB)
avatar image Alex O ♦♦ STAFF Feb 23 '18 at 03:55 PM

Insanity! I think best path forward would be to narrow down what you added for a solid repro.

avatar image CrowPath Feb 23 '18 at 05:15 PM

Yeah, I'll do a full investigation and bug-report submission once I've got this new release out of the way.

avatar image Matthew J ♦♦ STAFF Feb 23 '18 at 06:33 PM

Hello CrowPath,

I just wanted to add that I looked at this with Alex by debugging the project and it seems that, for whatever reason, the Level is being recreated 2 times, resulting in BeginPlay being called 3 times in total. It would be helpful if, as Alex mentioned, get a good repro and provide us with the map with all of the logic that is causing this to occur in the first place.

avatar image CrowPath Mar 12 '18 at 06:48 PM

I've been trying to recreate the steps that led to this for a few hours with no success. I'll keep at it, but for now here's the project files that I saved just after it started firing three times.

(comments are locked)
10|2000 characters needed characters left

its a known issue in the community. one way so solve the issue is to use a do once node then have a delay to the reset.

more ▼

answered Feb 23 '18 at 03:47 PM

avatar image

10k 33 8 23

avatar image Alex O ♦♦ STAFF Feb 23 '18 at 03:54 PM

Even with a "Do Once" node it still fires 3 times. (Just tried adding delay, same behaviour)

avatar image Thegamerguynz Mar 16 '18 at 03:37 AM

I'm having the same behavior in 4.18, any idea how to fix this?

avatar image Der_Grummler Mar 26 '18 at 07:58 PM

I ran into the same problem, that suddenly the Level Blueprint created, although I used a DoOnce Node, 2 Widgets at the same time. When I printed the Display Name of the Level Blueprint to Screen, it showed "MyLevel1" and "MyLevel5".

The Bug occured randomly when I was working on the Level Blueprint. The only things I recognized before were that when I pressed "create new Variable" an unrecognized "MyBlueprint" Tab occured and "Save All" showed some Blueprints I did not edit.

Engine Version: 4.18.3

(comments are locked)
10|2000 characters needed characters left

This just happened to me in 4.19.2, total crazinesss

more ▼

answered Aug 06 '18 at 04:40 AM

avatar image

11 1 2

(comments are locked)
10|2000 characters needed characters left

any news on this ? i just had the same problem event begin play fires twice even using do once it keeps firing twice im using 4.18.3 this is the second time it happens to me

more ▼

answered Sep 28 '18 at 08:53 PM

avatar image


(comments are locked)
10|2000 characters needed characters left

also got the "BeginPlay fires twice" problem on 4.20.3. Migrating the level to a clean project did not work, still firing twice.

more ▼

answered Oct 05 '18 at 06:36 PM

avatar image

1 2

(comments are locked)
10|2000 characters needed characters left

Did someone found any solutions to this? After two months on working on a project all my actions from my level bp are fired twice. The problem occurred after I've updated to 4.21.2 but in the same day I've create streaming levels, so I don't know exactly what is the problem. I've created a copy to the project and delete everything and Begin Play still fired twice. I also have another level and there is working without any problems. Thank you!

more ▼

answered Feb 21 '19 at 03:43 PM

avatar image

15 2 3

avatar image Tredigraph Feb 21 '19 at 05:03 PM

i think it may happen when you update a projects to a new version. If you make a blank projects whit the last version probably will works fine. if that's the case so it's a bug...

avatar image butavpaul Mar 07 '19 at 08:01 AM

The problem appeared on the same level engine version.

(comments are locked)
10|2000 characters needed characters left

i had the same problem...begin play of thirdPersonChracterBP executing twice.....then i figure out that i accidentally put a thirdPersonChracterBP ref. inside the map....and that was causing this problem..

more ▼

answered Mar 04 '19 at 02:19 AM

avatar image


(comments are locked)
10|2000 characters needed characters left

I have the same problem with 4.21

more ▼

answered Apr 22 '19 at 01:32 PM

avatar image

1 1 2

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question