x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

After load a second time one streaming level in a network game, all the object with static mesh components has the mesh empty

Hello to all, We had a game for two players. The first player directs to the second player and chooses the level that this second player see. The sequence is: the first player choose a initial level, the two players go the the correct level. Then chooses a second level and again the two players go to the correct level. If first player chooses the first level another time, when the two players go to the correct level, all the actors of this level have its static mesh components empty.

We use a permanent level with all selectable levels and we load/unload levels using streaming loading.

Each level has a directional light and several point lights. We build the light hiding all levels except the level that we want to build the lights. When the build finished we save all the levels.

Thanks In advance

Product Version: UE 4.18
Tags:
more ▼

asked Feb 11 '18 at 07:39 PM in Blueprint Scripting

avatar image

RubenYam
16 1 1

avatar image ThompsonN13 Feb 11 '18 at 07:48 PM

so when you reload the first level no objects are visible? im assuming you unload the streaming level then reload it. given that did you make sure to check the make visible after load checkbox.

avatar image RubenYam Feb 11 '18 at 07:58 PM

Yes, I have the Make visible after load checked. The second time the objects are no visibles but they are in the level. I can see its in the editor world outliner. But the mesh is empty.

avatar image Metafobia Jun 26 '18 at 08:32 AM

We've experienced the same issue in 4.19. Did you find a fix for the issue?

We can reproduce it by starting in our menu, then entering a level (with a loaded sub-level). Then if we reload the level, the sub-level has the issue explained, that is, no meshes. If we reload again, the issue is fixed. This means that every second time we load the level, the issue appears, but only if the first load is from another level (menu in our case).

In addition, the issue only appears in PIE and not in stand-alone.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Metafobia, Yes the problem appeared only in PIE. A build works well.

more ▼

answered Jun 26 '18 at 03:35 PM

avatar image

RubenYam
16 1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question