x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Masked material on huge particles black flickering

Hi,

I've been doing some FX work lately and for test's sake decided to switch to masked material to test things out and i've noticed strange black flickering on it. I've isolated the issue as far as i could and this is what i've come up with.

This is how the flickering looks like: https://gyazo.com/96150e8b224a85a0f5df1bf64a86356f

And this is the material, its pretty simple. It also flickers for a default lit masked material:

alt text

This is how the particle system looks like (you can even see the flickering in there):

alt text

To reproduce this effect i just have to:

  1. Launch an empty project or a template

  2. Create a masked material, like shown above

  3. Create a particle system

  4. Set our newly created masked material as the emitter's material

  5. Change the initial size of the particles to a bigger number, like 500 in X and Y.

The effect is the most visible when the Screen Alignment is changed to PSA Velocity, though it also flickers in other screen alignment modes. I reproduced it many times on 4.18.3 in few projects, though on 4.17 it doesn't seem to happen. It is also worth pointing out that i am running on Radeon RX480 and AMD FX-8350, since one of my peers couldnt reproduce the issue on his Titan card and Intel cpu.

Can anyone except me reproduce this issue? Or maybe someone has an idea on how to fix it, since my eyes hurt from constant flickering. Hope it will just go away in 4.19.

Product Version: UE 4.18
Tags:
more ▼

asked Feb 12 '18 at 07:53 PM in Bug Reports

avatar image

doosead
11 2 2

avatar image IndieGameCove Apr 28 '19 at 07:42 PM

I've got the same issue. happens even when I only spawn one particle. only effects cpu particles, the gpu particles work fine. I have an intel i5-7600k and a gtx 1070 dbuffer decals setting has no effect for me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It seems like it is not a bug, but a typical z-fighting issue. If you are set on using masked particles, give them more spacing between each other.

more ▼

answered Feb 12 '18 at 08:43 PM

avatar image

Deathrey
7.8k 130 31 293

avatar image doosead Feb 12 '18 at 09:23 PM

If its just z-fighting, its oddly specific that it does so only on this engine version and only on my setup, as my peers dont have the issue on theirs. Also, it happens for particles that are apart from each other too, as thats how i noticed it. I can post a video of it if you want to see it.

avatar image Luos Feb 13 '18 at 10:42 AM

This is Z-fighting. take it from someone who has been working/playing with unreal engine since the first unreal and uses cascade every day.

its something that happens with opaque/masked meshes/sprites that are overlapping, and while it always happens the quality of gpu/anti alliasing/filtering can change how it looks a little. this happens on every gpu and cpu.

This especially happens when the particles are screen aligned meaning that all the sprites are aligning their surfaces causing z-fighting. use a variety of different location modules (sphere for instance) and velocity modules to randomize the location of the particles to avoid z-fighting.

avatar image doosead Feb 13 '18 at 12:26 PM

First of all, thanks for trying to help me out, i really appreciate it.

I checked if non overlapping particles have the issue too and indeed they do, here's the video: https://gyazo.com/aecdfd3614342ae313ae0f9f2eb1d69b

The artifacts exist even if the particles are extremely far away from each other: https://gyazo.com/a0062ab6c7be7ea4e7a54bcda48e3aa8

And thanks to you i began testing if i can reproduce the issue on other engine versions and i've learned that it is NOT 4.18 specific. I reproduced it in 4.16 and 4.17, the reason i noticed no issues earlier on 4.17 is because i've had DBuffer Decals turned off for some reason in project settings. Turning it on brings back the flickering.

That being said, turning off DBuffer Decals magically fixes the issue for me. Why does that happen, i have no idea, but im not sure if the black flickering is intended to happen with DBuffer Decals on, even though its a clean empty project and no decals are used anywhere.

avatar image Luos Feb 13 '18 at 12:45 PM

i tried with both dbuffer decals on and off, and used same cascade /material settings as you but I am not getting the same results: https://i.gyazo.com/8887e8c9d30d3cb56b8023cf3077d5ad.gif

This makes me wonder if your gpu might have a driver/hardware issue. best to wait until an unrealdev takes a look at it I guess.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question