Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Generate Visual Studio project files unable to compile

I'm trying to generate C++ files for my currently Blueprint project to ultimately create a dedicated server.

Whenever I try to create a C++ class file in my project, it comes up with this although, I don't have a compile button in UE as its a Blueprints project.

alt text

After getting this error, I have tried to then right click the .uproject file and click "Generate Visual Studio project files" but that process fails and comes up with this error.

 Running F:/Program Files/Epic Games/UE_4.18/Engine/Binaries/DotNET/UnrealBuildTool.exe  -projectfiles -project="H:/Games design/UE4 Projects/WeaponEngine Active/WeaponEngine 4.18/WeaponEngine.uproject" -game -rocket -progress
 Discovering modules, targets and source code for project...
 While compiling H:\Games design\UE4 Projects\WeaponEngine Active\WeaponEngine 4.18\Intermediate\Build\BuildRules\WeaponEngineModuleRules.dll:
 ERROR: h:\Games design\UE4 Projects\WeaponEngine Active\WeaponEngine 4.18\Intermediate\Source\WeaponEngine.Target.cs(6,14) : error CS0101: The namespace '<global namespace>' already contains a definition for 'WeaponEngineTarget'
 ERROR: UnrealBuildTool Exception: Unable to compile source files.

Any tips?

Product Version: UE 4.18
more ▼

asked Feb 13 '18 at 12:31 AM in Using UE4

avatar image

33 8 10 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Delete the following temporary folders: Binaries, build, intermediate and saved. Delete the visual studio project file, if existing.

Open the unreal project file. Afterwards right klick on the project file and create the visual studio project file.

more ▼

answered Feb 13 '18 at 01:27 PM

avatar image

196 6 6 15

avatar image dscottwilson Feb 13 '18 at 01:51 PM

It worked. I deleted Binaries, Build and Intermediate which then allowed me to add a C++ class successfully.

avatar image Lobotomiac Dec 11 '18 at 06:48 PM

Hey there. I had a similar error when trying to Generate VS files, but only in case if I deleted the Saved folder. I failed to find any reason for this and if perhaps anyone here could share info on why that is that would be awesome. Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question