x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No HRTF option with Steam Audio or Resonance Audio

Hi!

I made a fresh install of UE 4.19 Preview to be able to use the newly implemented Steam Audio and Resonance Audio. However, after I did everything according to the manual like adding -audiomixer to the startup command line and editing the project settings I still do not get the option to use "SPATIALIZATION HRTF" as the desired spatialization method. The edit window does not even look like the one in the manual...

These are my project format settings. settings

My attenuation settings look like this: my settings

But they should look like this:

real settings

I also have the option to add an attentuation plugin setting further down in the edit window, but adding a spatialization plugin like the one below does not make any audible difference. plugin

The same problem exists when I am trying to use Resonance Audio...

Does anyone know what I am doing wrong?

Product Version: UE 4.19 Preview
Tags:
more ▼

asked Feb 13 '18 at 02:17 AM in Using UE4

avatar image

oggethealmighty
1 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi oggethealmighty,

The GUI for adding plugins changed between versions 4.18 -> 4.19 of Unreal. The "SPATIALIZATION HRTF" is no longer available in 4.19 (has replaced with 'Binaural'). So, the settings that you have in pics 1, 2 & 4 look correct (pic. 3 shows the 'old' GUI).

One thing you might want to check is the channel count in your audio asset? AFAIK, Unreal currently allows for spatialization of mono sounds only (although I'm pretty sure there would be silence if your asset is stereo...).

OOC, Have you tried changing the 'Spatialization Method' from 'Binaural' to 'Panning' (and back) while previewing the game in the Editor (PIE)? There should definitely be an audible difference when you do that.

more ▼

answered Feb 15 '18 at 01:33 PM

avatar image

mgudk
6 1 3

avatar image oggethealmighty Feb 15 '18 at 04:51 PM

Thank you for your answer!

Yes I installed 4.18 and used Steam Audio in that version instead and noticed that it worked flawlessly there! And yes, I did notice a difference between binaural and panning but I thought that was Unreal's default spatialization methods and not Steam Audio!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question