x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Share InputAction between blueprints

Hello,

I tried to share this Event by uncheck consume input, but it doesn't work.

Product Version: UE 4.18
Tags:
more ▼

asked Feb 13 '18 at 06:15 PM in Using UE4

avatar image

shaynox_
35 2 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Are you sure both actors are set to receive input? In the level editor Details panel there's an Input section for the selected Blueprint where you can enable Auto Receive Input for a specific player index (Player 0 is the local player for online / first player for local games), as it is set to Disabled by default. If you set Auto Receive Input here, it will only apply to the selected instance of the Blueprint.

Details Panel Input Settings

You can also do this inside the Blueprint's Class Defaults section, where there's an additional Block Input option. This should be unchecked to prevent it from blocking input to actors below itself in the input stack. If you set Auto Receive Input here, it will apply to all instances of this Blueprint, unless manually disabled via the method above.

Blueprint Class Defaults Input Settings

Also if one actor is the subclass of the other, you probably need to disable Override Parent Binding on the Input Axis/Action Event node (same place you unchecked consume input) if you want it to perform both the parent's action and the child's action for the same input.

I hope this helps!

more ▼

answered Feb 13 '18 at 06:50 PM

avatar image

Chromarict
144 1 1 3

avatar image shaynox_ 5 days ago

Thank you, I changed the auto receive input to player 0 to the secondary blueprint and it's work, and even if the consume input is on.

But the main character blueprint work even is the auto receive input is disable, strange.

avatar image Chromarict 5 days ago

I'm glad you got it working! :)

The main character still receiving input is probably because when you start playing the game spawns a PlayerController and Pawn for you and automatically sets up player input on it. This seems to always override the Auto Receive Input setting in both the PlayerController and Pawn.

The difference Auto Receive Input makes is that things other than the player can still receive input. So, while the game mode creates a PC and Pawn for you that always get your input, you can also have stuff loaded with the level or dynamically spawned during play that will also receive that input.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question