x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't call local host in exe

Hello Everyone,

I just finished the tutorials on the unreal youtube channel for the third person blueprint networking game and I have a question.

I built an executable (debug and shipping) and tried to get a network game with no luck.

I was able to get a successful listen server in the editor, but not with the .exe

I have made two shortcuts and placed in the following code in the target: server: ...\BlueprintReplication.exe" BlueprintReplication.exe Example_Map?listen -game client: ...\BlueprintReplication.exe" BlueprintReplication.exe 127.0.0.1 -game

Ran the server first and then the client, but they both open separate games.

Tried to do this manually in two regular versions of the game but no luck.

I think I followed the tutorial correctly so does anyone know what I am doing wrong? do I need to do something special when packaging? or do I have the commands wrong?

Thank you!

Product Version: Not Selected
Tags:
more ▼

asked Jul 29 '14 at 12:49 AM in C++ Programming

avatar image

omalleym
8 4 7 10

avatar image omalleym Jul 29 '14 at 01:59 AM

so someone said on a other post to look at the log files and in the clients version I saw this:

[2014.07.29-01.51.49:443][ 2]LogNet: Host name resolution failed with 48 [2014.07.29-01.51.49:465][ 3]LogNet:Warning: Network Failure: PendingNetDriver[PendingConnectionFailure]: Your connection to the host has been lost. [2014.07.29-01.51.49:465][ 3]LogNet: NetworkFailure: PendingConnectionFailure, Error: 'Your connection to the host has been lost.'

not sure what that error 48 code is and I can't seem to find it anywhere on the site

avatar image omalleym Aug 04 '14 at 09:56 PM

Any help would be appreciated! I don't want to try to implement anything unless I can get the executable to be able to handle networking!

avatar image Decca May 24 '17 at 06:23 PM

I'm also having this problem. Please help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question