x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Right Mouse button is stuck in blueprint editor

I have tried this on two different machines with at least 5 different mouses. This is an Unreal bug. There have been several other questions on this topic and no one has been able to figure out the cause. The only time i am able to consistently reproduce the issue is by launching my project in the blueprint view port to my title screen where I have only UMG Buttons. After clicking on one of the choices and closing the project back to the unreal editor I cannot right click and drag to move around the blueprint editor and the selection square comes up instead. The only way to fix this is to completely close the editor and restart it. Has there been any more progress on fixing this bug?

Product Version: UE 4.18
Tags:
more ▼

asked Feb 17 '18 at 06:05 PM in Blueprint Scripting

avatar image

MStory
19 1 8 8

avatar image M.FatihSaglam May 02 '18 at 03:48 PM

Same problem ! Still no updates on this. Edit: It happens after playing game in editor. (PIE)

avatar image llll Sabre llll Jun 04 '18 at 05:13 PM

Same for me.

Here are some notes in case it helps repro the bug:

  • I am running UE 19.2.

  • I load a project, open a blueprint or two and start working. (adding/deleting nodes, copy/pasting, attaching/unattaching, making variables etc). After a while suddenly the right mouse button brings up the selection box every time I right click (as well as the blueprint menu). I can no longer right click to scroll around a blueprint. I believe I have always run the project in PIE at some point before it happens, but I can't swear to it.

  • This is happening frequently. (On some occasions this is more than once an hour).

  • A close and restart of the engine is the only way I know of so far to fix it.

I understand that this one might be difficult to repro, so perhaps someone could look into the related code regarding right-clicking in a blueprint window, and the right click and drag code etc? Perhaps they could see how this problem might occur? Thanks.

avatar image markus_zhang May 01 '19 at 02:47 AM

Same problem! Everytime I right click in the editor it crashed immediately! Guys you need to fix this...everytime. I already sent the crash report.

avatar image Araan95 Jun 17 '18 at 03:31 PM

Same problem

avatar image namuol Jul 22 '18 at 08:59 PM

Experiencing the same issue in 4.19.2-4033788+++UE4+Release-4.19 on OS X. Seems to happen after running preview mode.

One alternative workaround: Open preview mode and try right-clicking, then hit ESC to quit. Worked for me at least once.

avatar image Element808 Jan 06 '19 at 09:46 AM

Confirmed this works in 4.20.3. Mahalo for that workaround @namuol!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Same problem here!

more ▼

answered Feb 28 '18 at 06:42 PM

avatar image

Duuhannes
31 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Same problem +1

more ▼

answered Mar 11 '18 at 04:17 AM

avatar image

wzspdw
76 5 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

no me funciona

more ▼

answered May 02 '18 at 03:59 PM

avatar image

raptor car
6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question