x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Imported animations come up empty

As title says.

I imported a skeletal mesh from blender, everything fine. The main root bone is called just "root".

Then i go to import an animation, i select the previous imported skeleton, and the animation come up empty.

I dont have a clue whats going on. I dont know if im doing something wrong in Blender when exporting or doing something wrong on UE when importing.

I already tried this method with the same result.

I noticed that in the output log i get tons of bone transform errors i also dont know why.

Thanks in advance

Product Version: UE 4.18
Tags:
more ▼

asked Feb 18 '18 at 03:08 AM in Using UE4

avatar image

amstradcpcuser
31 4 9 13

avatar image Paul Swartz Feb 21 '18 at 11:03 PM

Blender to Unreal can sometimes be a nightmare. I've made tutorials about it but I handle everything on a case by case basis as I sometimes still get the strangest errors.If you're willing to share the file I can have a look for you and maybe provide a solution.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Know this sounds like a no-brainer, but check and make sure your entire hierarchy is parented to your root bone (i.e. not having multiple roots). I was having same issue, but unlike most times UE wasn't spitting errors out at me for some reason. Hope this helps.

more ▼

answered May 05 '18 at 07:47 PM

avatar image

king-worm
60 4 5 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question