x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS - Build Error (Deployment Failed!)

Hey Guys!

I seem to be running into a couple of hurdles getting my game running on iOS. I managed to set up the certificates and provisions fine and don't run into any problems until I go to launch the project on my phone and run into the following errors:

LogPlayLevel: Setting up ProjectParams for C:\Users\Zac Rodger\Desktop\Projects\TunnelRun3\TunnelRun3.uproject LogPlayLevel: BUILD COMMAND STARTED LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.751967 LogPlayLevel: Running: E:\UE_4.18\Engine\Binaries\DotNET\UnrealBuildTool.exe TunnelRun3 IOS Development -Project="C:\Users\Zac Rodger\Desktop\Projects\TunnelRun3\TunnelRun3.uproject" "C:\Users\Zac Rodger\Desktop\Projects\TunnelRun3\TunnelRun3.uproject" -NoUBTMakefiles -remoteini="C:\Users\Zac Rodger\Desktop\Projects\TunnelRun3" -skipdeploy -ini:Game:[/Scri pt/UnrealEd.ProjectPackagingSettings]:BlueprintNativizationMethod=Disabled -noxge -generatemanifest -NoHotReload LogPlayLevel: Picking the default remote server LogPlayLevel: ERROR: Remote compiling requires a server name. Use the editor (Project Settings, IOS) to set up your remote compilation settings. LogPlayLevel: version:4.18.3 LogPlayLevel: Doing xcode-select --print-path LogPlayLevel: ERROR: Failed to start local process for action ("Cannot start process because a file name has not been provided."): -o BatchMode=yes ${CURRENT_USER}@ "cd \"/\" && xcode-select --print-path" LogPlayLevel: Took 0.7931083s to run UnrealBuildTool.exe, ExitCode=5 LogPlayLevel: ERROR: Command failed (Result:5): E:\UE_4.18\Engine\Binaries\DotNET\UnrealBuildTool.exe TunnelRun3 IOS Development -Project="C:\Users\Zac Rodger\Desktop\Projects\TunnelRun3\TunnelRun3.uproject" "C:\Users\Zac Rodger\Desktop\Projects\TunnelRun3\TunnelRun3.uproject" -NoUBTMakefiles -remoteini="C:\Users\Zac Rodger\Desktop\Projects\TunnelRun3" -sk ipdeploy -ini:Game:[/Script/UnrealEd.ProjectPackagingSettings]:BlueprintNativizationMethod=Disabled -noxge -generatemanifest -NoHotReload. See logfile for details: 'UnrealBuildTool-2018.02.18-21.34.25.txt' LogPlayLevel: (see C:\Users\Zac Rodger\AppData\Roaming\Unreal Engine\AutomationTool\Logs\E+UE_4.18\UAT_Log.txt for full exception trace) LogPlayLevel: AutomationTool exiting with ExitCode=5 (5) LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.250157 LogPlayLevel: BUILD FAILED PackagingResults: Error: Deployment failed! Unknown Error

I've been checking everywhere online for a fix and went over the plugins to make sure there's issues there too. I've been having a couple of other problems prior to this which I managed to get through but I'm unsure if it's related.

Really hope you can all help!

Thank you.

Product Version: UE 4.18
Tags:
more ▼

asked Feb 18 '18 at 10:44 AM in Packaging & Deployment

avatar image

Rodger That
1 1 1

avatar image fortesdev Mar 07 '18 at 10:29 PM

I have the same issue: my project was working fine in 4.18, no plugins or c++ code in it. But after updating to 4.18.3 (and even cleaning things up) it complains with the same error as above. Kind of frustrating. I wanted to update as iOS icons were not deployed to device (Unreal devs, wtf) and now is even worse. You should dedicate a little more effort to mobile guys.

avatar image fortesdev Mar 16 '18 at 10:16 PM

Problem persists with 4.19 release. Congratulations Epic.

avatar image Rodger That Apr 17 '18 at 06:49 AM

Managed to get past this one but sadly the solution was to build the project on a mates Macbook... Certainly not the solution I was looking for and sadly seems to have only fixed one of a long line of issues launching for iOS

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question