x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is my Animation invisible?

Hi, I have imported a skeletal mesh, which seemed to work fine. Later I imported an animation, but when the mesh plays the animation, it becomes invisible. First I thought, that something went wrong during the import. So I deleted the animation and imported it again. Same result. My next step was to use an *.fbx from an older project, which I successfully imported in that older project. Same result. Mesh is visible, but the animation isn't. As next I imported the full mesh and animation at the same time. Probably something with the skeleton choice went wrong. Same result, mesh looks fine, animation can't be seen. The mesh also becomes invisible, if I am placing it in the world an choosing an animation asset. I also checked the wire frame... the mesh is entirely gone. I made some screenshot, of an dummy mesh to test it again. I don't know what went wrong with my FBX from Blender. I hope that you can help me, fix that problem.

alt text

Best regards,

Tarek!

Product Version: UE 4.18
Tags:
import-mesh.png (73.1 kB)
egg-mesh.png (1.0 MB)
egg-skeleton.png (866.7 kB)
egg-animation.png (590.4 kB)
more ▼

asked Feb 19 '18 at 04:57 PM in Using UE4

avatar image

TsDev
1 1 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Found the solution in this Post: https://answers.unrealengine.com/questions/729192/animation-import-problem-1.html

To bad that I haven't found this one before posting. Sorry about that.

more ▼

answered Feb 19 '18 at 05:01 PM

avatar image

TsDev
1 1 2 1

avatar image ThompsonN13 Feb 19 '18 at 05:43 PM

did it work? i figured it was the scaling issue that has plagued the blender to ue4 import process.

avatar image TsDev Feb 19 '18 at 06:40 PM

How would you have fixed this problem? And yes it worked. At least for the ugly dummy egg.

avatar image I Create Art! Feb 19 '18 at 10:01 PM

If root lock fixed it then I think your root bone is not in a proper location in the animation, it's probably out in space somewhere. Could be a mistake you made or a problem with blender/fbx.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question