x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[bugreport] Creeping shadows in light

Lightmass is having trouble with edges. Calculations cause a shadow to appear even in direct lighting when using a sharp edge. I have found no way around this. Is there a way to disable lighting on a model so that I can bake the light & shadows in the 3d program instead? This is a very worrying effect, that I cannot work with.

UPDATE: When using preview quality I don't see this. As noted in the image it becomes apparent with higher quality setting.

UPDATE #2: I decided to check the UV's as recommended by Roel. And much to my surprise there is indeed something going on. I updated this post with the settings I use, and a image showing what UE4 use. They don't match. Now to be clear, I adjusted the UV's and reimported the model, but the UV still remains as they were in the beginning (I thought), but rather it is using the UV from the lightmap, and applies them to the textures too. The position of the UV's in the texture layer isn't the same as in the lightmap (they are offset there). I will check if adjusting the lightmap UV's matter. But this does look interesting.

UPDATE #3: I aligned the UV's so they are the same, but the leaking still happens. So UV's don't seem to have anything to do with it as far as I can tell :( (Not happy)

UPDATE #4: Roel led me to the correct issue. The second UV channel had the size 32 instead of 64. Correcting this and connecting the edges solved the issue. Many thanks to Roel :)

See here:

(EDIT: I had to remove these links as the pictures are now gone.)

Product Version: Not Selected
Tags:
more ▼

asked Jul 29 '14 at 11:31 AM in Bug Reports

avatar image

Mithril
124 11 12 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Did you check your light map uvs (channel 1)? It looks like a uv error.

more ▼

answered Jul 29 '14 at 11:59 AM

avatar image

Roel
2.4k 69 42 141

avatar image Mithril Jul 29 '14 at 12:10 PM

I've got two UV channels. Both are the same if this is what you are thinking of? What error in particular?

avatar image Roel Jul 29 '14 at 03:46 PM

Probably your light map resolution you can change it in the static mesh editor.

avatar image Roel Jul 29 '14 at 03:48 PM

Ohh, and another thing, try to make the edges connected in your uv's, it will show no lightmap errors in places where the edges are connected.

avatar image Mithril Jul 29 '14 at 04:15 PM

Thanks a bunch Roel :) That was exactly it. The second channel was set to 32 instead of 64 like the first one. And fixing the edges helped too.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In your picture, it looks as if the UV mapping for the light map channel is not leaving enough margin for the right side, and also not for the top side for the topmost rectangles. Also the lighting problem seems to be with the top face, not the side faces, so the faces you are showing in your pictures are not the ones with the problem, so we can't tell whether there's a problem on the top face.

more ▼

answered Jul 29 '14 at 04:04 PM

avatar image

jwatte
1.3k 48 41 88

avatar image Mithril Jul 29 '14 at 04:19 PM

@jwatte. Roel was correct. The second channel had a map setting too small. So even though both UV channels were identical when exported. After having imported them, the second channel became half the size of the first one. Fixing that solved the issue. And connecting the edges solved the last bit of weird shadowing as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question