x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Assertion failed: isValid() sharedpointer.h line 835

Hey, my project compiles and runs with no struggle in the editor but gives an assertion error at launch when packaged, "Assertion failed: isValid() sharedpointer.h line 835".

Log errors: 0x00000000DA373FB8 KERNELBASE.dll!UnknownFunction [] 0x00000000647DEED0 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x000000006421B0EB CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000641A5CA8 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000640402CA CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000640394AC CFM-Win64-DebugGame.exe!UnknownFunction [] 0x000000006401087F CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000640157E8 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x0000000064015CE3 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000648571CC CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000648BE05F CFM-Win64-DebugGame.exe!UnknownFunction [] 0x0000000064903AF1 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000648AA1EE CFM-Win64-DebugGame.exe!UnknownFunction [] 0x000000006499EC6E CFM-Win64-DebugGame.exe!UnknownFunction [] 0x0000000064951D42 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x000000006492575E CFM-Win64-DebugGame.exe!UnknownFunction [] 0x0000000064092F53 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000640A3D42 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000640A3EBA CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000640B03C8 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x000000006761C5B6 CFM-Win64-DebugGame.exe!UnknownFunction [] 0x00000000DAFC1FE4 KERNEL32.DLL!UnknownFunction [] 0x00000000DD77EF91 ntdll.dll!UnknownFunction [] 0x00000000DD77EF91 ntdll.dll!UnknownFunction []

Thanks :)

Product Version: UE 4.18
Tags:
more ▼

asked Feb 20 '18 at 11:13 AM in C++ Programming

avatar image

legobrainiac
6 1 2 4

avatar image j.mueller RFG Feb 20 '18 at 01:01 PM

I doubt that anyone will be able to help you with this issue from little more than raw memory addresses. To figure out why your pointer is uninitialized I would recommend to build and run your project with a debug configuration, so you are able to locate where in your program flow the isValid call fails. Then you can investigate why your pointer is invalid at this moment or why some code is trying to do something with it although it is still uninitialized and fix it. If you should get stuck with this please provide a human readable stacktrace.

avatar image legobrainiac Feb 20 '18 at 01:12 PM

Thanks for the answer, i'll get on with it when i get home :)

avatar image legobrainiac Feb 21 '18 at 03:41 PM

I got the debug symbols for the project but since the game crashes immediately i can't attach the process.

avatar image legobrainiac Feb 21 '18 at 04:11 PM

Was able to attach the debugger at launch with the reattach plugin and i found the problem.

 static const FSlateBrush* GetBrush( FName PropertyName, const ANSICHAR* Specifier = NULL )
     {
         return Instance->GetBrush( PropertyName, Specifier ); // Hit breakpoint here
     }

I have a custom slate widget in game wich is using a brush from the editor. Possible that the packaged version does not compile with that brush, i'll find my way arround it.

Thanks for the help

avatar image j.mueller RFG Feb 21 '18 at 04:24 PM

When I consider that the validity check is performed in TSharedPtr::operator->(), my guess would be that it is not the brush but the instance that is uninitialized.

avatar image rexy729 Feb 21 '18 at 01:20 PM

I got same error. Detail is attached.link text

UE 4.19 Preview, Windows 10, Visual Studio 2017

crashcontext.txt (14.0 kB)
avatar image RiverBruce Jul 15 '18 at 03:47 PM

i got the same error when i start the .exe file. and the error like this: alt text

so do u solve it,legobrainiac ,and how?

z73-v3m6d-wpl.png (11.6 kB)
avatar image legobrainiac Jul 15 '18 at 03:52 PM

You need to attach the visual studio debugger to your game project and step through it until you find the problem. Look up how to do that. Also look to see if you're using any brushes that are particular to the unreal editor in your code. That was my problem last time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I found out the main problem is that I use widget.

**UPROPERTY(EditAnyWhere, Meta = (MakeEditWidget = true))

FVector TargetLocation;**

more ▼

answered Feb 21 '18 at 05:45 PM

avatar image

rexy729
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I experienced this error, too, but I was launching onto an Android device and from your output it appears you launched onto Windows. Clicking "Build" and saving all changes resolved this error for me. I noticed in the description it says that it updates Brush Models; so, maybe that is related to why you found the error occurring at the GetBrush function. This probably should be submitted as a bug report, but I will have to discover how to re-create this error in a new project.

more ▼

answered Jan 16 '19 at 04:56 PM

avatar image

Spidermined
86 3 6 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question