x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Standalone game does not progress past intro movies if there is no audio device

Hi Epic!

I've encountered an issue with Unreal this morning when there are no audio devices available to play sound, or "-nosound" is specified in the launch params. I think having startup movies is a requirement for this to happen, since I can run the game inside of the editor just fine.

Repro steps:
1: Make sure your launch parameters are -nosound or there are no audio devices available
2: Have at least one startup movie
3: Configure the movie player like so:

 [/Script/MoviePlayer.MoviePlayerSettings]
 bWaitForMoviesToComplete=True
 bMoviesAreSkippable=False
 +StartupMovies=*MOVIEGOESHERE*

4: Launch standalone
5: Observe how the game never displays any intro movie

The problem does not occur when bWaitForMoviesToComplete is false

I hope I've provided enough info for you guys to go on, I haven't tested this in a fresh project.

Product Version: UE 4.18
Tags:
more ▼

asked Feb 21 '18 at 10:27 AM in Bug Reports

avatar image

JoppeT6
1 1 1

avatar image Sean L ♦♦ STAFF Feb 22 '18 at 02:08 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1410408-unreal-engine-bug-submission-form

Thanks

avatar image JoppeT6 Feb 22 '18 at 02:51 PM

Thank you! Submitted the bug through the form!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question