x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is a model light flashing in shadow?

UPDATE: I found the issue with sun shining through the meshes was due to the sun being a directional stationary light. Changing it to a static light solved that issue. However...

Now when in shadow the light on the FPS model flashes. I posted a playable level earlier showing this very thing. Here is an image:

Flashes

I only moved a degree between these two images. Also notice the horrible banding happening. Does anyone have any idea why this happens? This is the second time I mention this, but no answer as of yet.

Here is a small playable level showing all the weird things surrounding lights. Enter the dark area and move/turn slowly. Try shooting balls to the ceiling you will also see light clearly leaking in en masse.

(EDIT: I had to remove these links as the files are now gone.)

This is the link to the earlier post I did: Playable

Best regards/ Mike

Product Version: Not Selected
Tags:
lightflash.jpg (36.8 kB)
more ▼

asked Jul 29 '14 at 06:11 PM in Using UE4

avatar image

Mithril
124 11 12 19

avatar image TJ V ♦♦ STAFF Jul 29 '14 at 07:59 PM

Hi Mithril,

Could you post your dxdiag?

Stationary is considered the lowest quality lighting although you have faster render times. Try setting the Directional Light to Dynamic.

Another thing to try is test it in a room that doesn't have mirror-like reflective surfaces.

If the issue still persist, could you post a link to download the project so we can test it in house?

avatar image Mithril Jul 29 '14 at 10:26 PM

Hello Ballard, I tried setting it to dynamic but no change. So I packed the project up and added it for you to download. It's quite small 12Mb. The reflective surface is removed, but it doesn't change anything. Also the mesh I create have a small angle at the edge, quite deliberatetly placed because I wanted to see how much leakage there is. And as it turned out, it is a lot. But this won't affect the flickering. Changing the mesh to a BSP wall still causes a flicker. And for the purpose of proving it, I added a BSP building next to it. Enter there and you'll see the same thing happening. I also added the DXDiag as a link, you'll se a few buckets. But those are quite old. The editor haven't crashed since I upgraded to 4.3, and they were related to the GPU overloading.

Many thanks for taking the time to look at this.

Best regards/ Mike

(EDIT: I had to remove these links as the files are now gone.)

avatar image Mithril Jul 30 '14 at 11:41 AM

I just wanted to add an image of the type of lighting I expected to see. (If it at all matters :) )

Correct

correct.jpg (40.6 kB)
avatar image TJ V ♦♦ STAFF Jul 30 '14 at 06:16 PM

I compared your level to my test bed and set everything identically but the flashing on your character mesh was still there. Could you test this in a new 4.3.1 project? Just add your room and only change the Directional light to Dynamic then build.

avatar image Mithril Jul 30 '14 at 07:34 PM

I changed the setting for the light in 4.3.1 as you requested, but I'm sorry to say that the flashing is still there. Just a thought.. could the flashing be caused (because I don't know how lighting information is stored or accessed in the areas) by several pieces of lighting information being stored at the same location. And the engine just randomly picks one because it doesn't know which to pick? That is assuming you have voxelized the lighting information per light source, or something similar.

UPDATE:

Just to clarify: I did the following in 4.3.1:

I created a new level from the blueprint level for FPS. Simply added a BSP house around the character.

Changed the light to Dynamic.

Built it, and ran it.

Still flashing.

Hope this helps. /Mike

avatar image TJ V ♦♦ STAFF Jul 30 '14 at 10:14 PM

Did you create a new level from the same project or a whole new project? If it was just the level, try retesting in a entirely new project.

Also, I noticed a new driver for your graphics card came out July 29th. Try installing it before you retest the issue.

avatar image Mithril Jul 30 '14 at 10:41 PM

I actually upgraded the driver earlier today :) I created a whole new project within 4.3.1. I just used the FPS sample you provide. The only thing added was the BSP mesh around the player, and of course the change in light to dynamic.

I also (for this question) moved a few boxes inside, to help illustrate that there is some light from the sides inside that volume.

Snap new431

new431.jpg (109.8 kB)
snap.jpg (48.5 kB)
avatar image Mithril Jul 30 '14 at 11:28 PM

I don't know if this is at all playing into things. But I did notice this. I used the glass material and placed it on a BSP section (all it's sides) Gave another material to the top BSP section (again all sides) And as you can see, it ignores part of the BSP section above it, making it see through. (Just in case that too got something to do with it?? )

Empty

empty.jpg (37.5 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

BSP will have light leaks unless they are overlapping by a good margin. This is just the way they were designed.

alt text

Also remember that BSP's aren't intended to be part of the final game, they should be replaced with custom made static meshes.

As far as the lighting on the player character (and perhaps the light leaks you are seeing as well), I narrowed it down to the Example Map. Could you make a new level and choose the Default map, then retest it?

I tested this in several new projects and the sample project you gave me. All the Example Maps have this issue. I submitted this for our developers to look into.

Thank you for you feedback, TJ

more ▼

answered Jul 31 '14 at 03:28 PM

avatar image

TJ V ♦♦ STAFF
41.3k 1008 181 492

avatar image Mithril Jul 31 '14 at 11:27 PM

Thanks TJ, happy you found something. Too bad for me though that there is something going on even with default. Not many trees here with the right coloration or lighting (speed tree) :/ One tree is even beginning to turn red. But I will work something out. I won't bother you guys with this any longer. Thanks for the help, and I hope the devs works something out.

Btw: The same lighting blinking goes on with the trees if dragged along the surface. Your devs might want to know about that :)

Light

lightmess.jpg (82.9 kB)
avatar image Mithril Aug 01 '14 at 09:07 PM

This is a final display on what a scene created from bare minimum (I think this is what you meant by Default map anyway) added some trees in SpeedTree, and dragged one along the surface. Light is dynamic (fully). Nothing else in this map. This is what it looks like (below) I presume this is what you have found also, but I wanted to show this because it isn't just a sample issue. It is actually a lighting issue in the engine as a whole.

Light

avatar image TJ V ♦♦ STAFF Aug 01 '14 at 09:39 PM

Hi Mithril,

This doesn't pertain to the original issue you were having with the Skeletal Mesh. For tracking purposes could you please post a new question with this info.

Thanks, TJ

avatar image Mithril Aug 01 '14 at 10:01 PM

Actually the original issue was a model, as in any model. The skeletal model just happened to be easy. The skeletal model have other issues too I didn't mention, like it's light blowing up in the screen when viewed in blueprints. And I also showed how it affects any model, and tried to show it's related but ok.. I won't argue. I'll leave this be and hope it get solved anyway. I've spent far too much time on this anyway :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question