x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project crashes on startup (C++)

Hi,

Having some problems, UE4 crashes at 71% when opening my project. Compiles fine in Visual Studio though.

I've tried removing Binaries folder and rebuilding project in VS - Compiled successfully but still doesn't work.

Tried removing the maps in case that was it - no change

Tried removing Autosave folder - nothing

I cannot see anything noticeable in the log files, please can someone help?

See attached log files here

Product Version: UE 4.18
Tags:
crashes.zip (397.3 kB)
more ▼

asked Feb 27 '18 at 11:08 AM in C++ Programming

avatar image

Enxa
1 2 5

avatar image Atheist91 Feb 28 '18 at 10:36 AM

Have you tried running your project with attached debugger?

@Down Ikr :p

avatar image Enxa Feb 28 '18 at 12:08 PM

Wow, great idea thanks.

How would i do this when the editor crashes on startup? How do I attach the process as if i attach it to the editor, by the time VS has sorted itself out, the editor has already crashed and VS says "Source not available"

Thanks

avatar image Atheist91 Feb 28 '18 at 01:10 PM

Open your project in visual studio.

From Debug menu select Start Debugging. (https://i.imgur.com/ALMwX0P.png)

Or simply hit F5.

avatar image AmphDev Feb 28 '18 at 10:44 AM

good point! :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Ok, managed to get it to work by removing the Saved, Interm and binaries folders, the .sln Right clicked the project and generated visual studio etc.. Loaded the solution up in VS and built solution.

Hopefully this could help someone else.

more ▼

answered Feb 28 '18 at 12:42 PM

avatar image

Enxa
1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

CrashDump say you have nullpointer, because its happens when you start editor i guess you did something wrong in some class Constructor (like you tried to getworld, or something like that)

cheers

more ▼

answered Feb 27 '18 at 01:41 PM

avatar image

AmphDev
1.5k 15 9 34

avatar image Enxa Feb 27 '18 at 02:14 PM

Hi, Thanks for your help.

I've removed the code that was implemented just before the crash (so i'm guessing that caused it) and it still doesn't work after re-building.

I have checked everywhere for null ptrs. :/

avatar image AmphDev Feb 28 '18 at 08:15 AM

Not enough if you checking nullptrs... if you try to call functions on constructor which not allowed, engine will still crash..

Double check you do not use any non allowed function in constructor..

If not.. well then problem can be in blueprint... and try to remove interm / saved dirs again..

avatar image Enxa Feb 28 '18 at 12:22 PM

I've removed all code and intermediate + save directories and still crashes. :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question