x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Light Settings Look Different in game vs when rendered

I'm new to UE4 so forgive me if this is a noob mistake.

I have a scene ready in UE4. When viewing the scene in the editor or in game mode it looks great.

However when I try to render the scene using the level sequencer the rendered version has so much more light than what it shows in game. Like the whole screen is virtually white. Here are some screen shots to compare:

alt text

alt text

The only thing I can think of that might be causing this is that I baked in the lighting for the scene sometime near the beginning. However halfway through my project I decided to go fully dynamic.

So what I did to get rid of the light-maps is I hid my entire scene in the world outline panel (by turning off the eye). Then I rebuilt the lighting with everything off, and it seemed to work because in game mode the lighting looked like the first screen shot you see.

However is it possible that these old light-maps are still there which make a mess for the rendered settings? Is there anything else I should look for?

Thank you so much for your time and help!

Edit: These are the settings I have under the "world settings" - "Lightmass" area:

Lightmaps: | 0 Lightmaps

Packed Light and Shadow Map Texture Size: | 1024

Force No Precomputed Lighting: | Checked

Product Version: UE 4.18
Tags:
arch.jpg (683.7 kB)
arch2.jpg (128.7 kB)
more ▼

asked Feb 28 '18 at 04:10 AM in Rendering

avatar image

yahsaves777
3 1 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi!

Maybe I'm wrong but I could never "exclude" meshes from light build just by turning the eye off... I had to set them as not visible (detail panel) and also turn off cast shadow... So it could be that you still have them in the scene but in your view mode they are overlapping and you see your desired dynamically lit scene... I might be totally wrong! ;)

more ▼

answered Mar 01 '18 at 12:23 AM

avatar image

Makigirl
1.3k 5 4 8

avatar image yahsaves777 Mar 01 '18 at 03:31 AM

Thank you for your reply! I tried what you suggested, but at first I was still getting the same results.

However by pure coincidence as I was editing the meshes to turn off cast shadows I accidentally deleted my skylight without realizing it and VIOLA! Everything was back to normal! Thank you so much even though your answer didn't directly fix it you still helped!

So somehow the problem was my skylight settings. It showed differently in the editor than in the render, but when I deleted the light and put it back in the scene everything is working now. Thanks again!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question