x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Server Error: TravelFailure: ClientTravelFailure, Reason for Failure: 'Servers can't open network URLs'

So I've seen a few posts like this but no one has an answer yet and they keep getting marked as answered I followed this guide to a T. https://wiki.unrealengine.com/Dedicated_Server_Guide_(Windows_%26_Linux)#2.a_Setup_source_unreal_engine_To_use_Visual_studio_2017 Did it twice, using Community 2015 Update 3 and UE4.18 RUNNING ON LOCALHOST TO TEST 127.0.0.1 using the FirstPersonExampleMap as the main map.

Heres my log: link text

Product Version: UE 4.18
Tags:
log.txt (19.8 kB)
more ▼

asked Mar 01 '18 at 01:22 AM in Packaging & Deployment

avatar image

TheOldWizard
6 1 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This is a new one for me. It looks like you should branch on "IsLocallyControlled" to make sure it's not running on a server or a non-owning client. The client can open a URL like that but a server cannot.

The engine code involved is UEngine::Browse(). It's in Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp.

more ▼

answered Mar 01 '18 at 01:44 AM

avatar image

Jin_VE
4.5k 32 79 42

avatar image TheOldWizard Mar 01 '18 at 01:51 AM

I mean I'll try taking a look.

avatar image TheOldWizard Mar 01 '18 at 01:58 AM

I mean i found the code snippet that logs Browse: URL to String but not the isLocallyControlled variable

avatar image Jin_VE Mar 01 '18 at 02:20 AM

It isn't a variable. It's a function. It returns true if it is called on a local client. You want to check that and if it is true then you should open the URL. If it is false then do nothing.

I was only giving you a reference to the code involved in case it helped. There's nothing there that you need if I'm right. But if I'm wrong, you have a place to look.

avatar image TheOldWizard Mar 01 '18 at 02:27 AM

isLocallyControlled isnt a function in that file hmm A search shows it in these directories https://gyazo.com/840e77e6a70cf36e608f35586cd01bbf but it seems to be affecting control of characters not client/server

avatar image Jin_VE Mar 01 '18 at 02:44 AM

It's called from the pawn. If you are doing something different then I need more context. What is happening when this problem occurs? If you can show some code that would help a lot.

avatar image TheOldWizard Mar 01 '18 at 03:31 AM

I get that. I’m only following the instructions to start a dedicated server

avatar image Jin_VE Mar 01 '18 at 03:40 AM

So you are specifically at this step? 3. Launch and test the server

The more information you give, the easier it is for us to help you.

avatar image TheOldWizard Mar 01 '18 at 04:03 AM

More than happy to provide answers. And yep right at step 3.

avatar image Jin_VE Mar 01 '18 at 04:11 AM

Are you running it with any command line parameters?

In Project Settings -> Maps and Modes, what is "Server Default Map" set to?

The error implies that somehow you are telling the server to open a URL. It also implies that this is not allowed. So we need to figure out where and how this URL is being given to the server -- because it is not normal.

avatar image TheOldWizard Mar 01 '18 at 04:15 AM

Happy to work with ya. I have it set to my map which is cleverly named FirstPersonExampleMap https://gyazo.com/d9b8075f03b07b5a2502df1497d5ac86 there are no command line parameters being run. everything is build and the builds have been successful.

avatar image Jin_VE Mar 01 '18 at 05:34 AM

OK. The log file says this "Browse: 127.0.0.1//Game/Maps/FirstPersonExampleMap". You need to get rid of that "127.0.0.1/" so it says "Browse: /Game/Maps/FirstPersonExampleMap". Basically, you shouldn't be giving the server the IP address like that. It will bind to 127.0.0.1 by default. However that is getting into the mix, get it out.

avatar image TheOldWizard Mar 01 '18 at 05:55 AM

Roger that. I have an idea perhaps. The only place i set 127.0.0.1 is this step 1. Prepare the project for packaging 2. https://d26ilriwvtzlb.cloudfront.net/4/47/Ip.png

So i might try removing that..?

avatar image Jin_VE Mar 01 '18 at 06:28 AM

Yeah. You can't run that on the server for sure.

And make sure when you do connect that it's happening on a client and not on a server. Easiest thing for now is to just connect the clients using the console command (the ` key brings up the console in a Development build). The command is "open 127.0.0.1". Once you get settled you can have the clients use the "ExecuteConsoleCommand" node and connect automatically.

avatar image TheOldWizard Mar 01 '18 at 06:41 AM

Right now im executing another build using the tutorial. if it still fails i'll try removing that node. but i wanted to try a clean game again. I'll post the results of both once im done

avatar image TheOldWizard Mar 01 '18 at 06:48 AM

Doing a clean build worked.However when clicking the project.exe I dont get the Join succeeded message https://d26ilriwvtzlb.cloudfront.net/0/05/Joinsuccess.png I get all the way to here: https://gyazo.com/6a9624348f3a982ace9322c44173a758 which is good No error this time but its just a black screen. They did have me delete the player start capsule and set the default map to the testLevel.

The thing is, when i click I hear the actions of my game, but see nothing. Just a black screen and no server log for a successful login. Hmm

avatar image TheOldWizard Mar 01 '18 at 06:54 AM

Solved that using your method of using ` open 127.0.0.1

avatar image Jin_VE Mar 01 '18 at 07:06 AM

The connection looks like it's good. It seems the problem is the client is using the Entry map, not the map you want it to. In the Maps & Modes section of Project Settings, there is a spot called "Game Default Map". If it's not already, set that to the same map as "Server Default Map".

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question