x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem with physic surface type in 4.18 - bug?

Hello

I have projectile blueprint, I not work on this project part in 4.18, doing other things. Now I see, UE can't find correct surface type. Is only default, rest is red, broken.

I have all need physic materials in project, it work with no issues in 4.17 and before, now I have error.

As you can see, I recreated new Get SurfaceType node and trying get it directly from hit result by Get Surface Type - all fails.

Any ideas?

Thank you!

alt text

Product Version: UE 4.18
Tags:
more ▼

asked Mar 01 '18 at 03:37 PM in Blueprint Scripting

avatar image

Vaheva
1.3k 24 29 52

avatar image infosimwave Apr 24 '18 at 09:21 PM

I'm seeing similar behaviour in 4.18 between Switch and Select Blueprint nodes as well as Physics Materials. I'm currently in the process of making a new project based on work from 4.15, and when I brought over my Select nodes from the previous project, all values were invalid like OP's picture.

I've added three new Physical Surfaces and regardless of wherever I try to set the Surface Type (or any Blueprint node that asks for a EPhysicalSurface), the only available option is 'Default'.

avatar image Vaheva Apr 24 '18 at 09:51 PM

Bad. I'm now on 4.19 and as I see, this is still broken....

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I don't know if this is helpful at all, but I did seem to solve my problem. Upon adding additional Surface Types to Settings > Physics > Physical Surface, I had to close and reopen UE4 (deleting Binaries/Intermediate folders might also help) so that the binaries could be recompiled. Once they were recompiled, the newly added Surface Types resolved and appeared correctly.

more ▼

answered Apr 27 '18 at 06:17 PM

avatar image

infosimwave
31 7 5

avatar image Vaheva Apr 27 '18 at 07:59 PM

Well, this is it. I forgot, because I set surface types long ago in other project, then I did migrate of blueprint. Firstly I set surfaces both in settings and as new types. This is confusing, I think after create new type, it should be added to settings automatically, many confusions and double work I think. Anyway - you solved it! :D

avatar image Vaheva Apr 27 '18 at 08:00 PM

Change this comment to answer, I will accept it - thank you!

avatar image infosimwave Apr 27 '18 at 09:45 PM

Glad I could help! I thought the same thing; as soon as I added the new Surface Types, I figured they would show up immediately. I just happened to recompile my binaries this morning and when the Surface Types I'd added appeared, I knew something was up. Best wishes!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question