x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can a Shader Plugin use the Settings Module?

I have a shader plugin, which has to load at the PostConfigInit stage.

During the StartupModule function, if I try to get the Settings module it just drops straight out of the function.

If I check if it's loaded and load it if it isn't, I get the settings interface back. However, then when I try to register the default object of my settings class from within my module I get an assert when it tries to get the DefaultMutableObject for my class. The code looks a bit like this:

 FModuleManager& ModuleManager = FModuleManager::Get();

 ISettingsModule* settingsModule = NULL;

 if (!ModuleManager.IsModuleLoaded("Settings"))
 {
     settingsModule = (ISettingsModule*)ModuleManager.LoadModule("Settings");
 }
 else
 {
     settingsModule = FModuleManager::GetModulePtr<ISettingsModule>("Settings");
 }

 if (settingsModule)
 {
     UObject* default = GetMutableDefault<UMySettings>(); // *** ASSERT HERE ***

     auto settingsSection = settingsModule->RegisterSettings("Project", "Plugins", "MyPlugin",
         LOCTEXT("MyPluginName", "MyPlugin"),
         LOCTEXT("MyPluginDescription", "Configure MyPlugin."),
         default
     );

     // etc 
 }

The error given is:

LogWindows: Error: === Critical error: === LogWindows: Error: LogWindows: Error: Assertion failed: Internal::GObjInitialized [File:D:\Build\++UE4+Release-4.18+Compile\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectBase.cpp] [Line: 171]

In other examples and samples I have found of this, none of them are doing at the PostConfigInit stage. So, I wonder if there's something else that needs to be up and running before the settings system will work?

I suspect I am just doing something daft.

If there's another sensible place I can register this, where would it be?

Thanks & regards, Robert

Product Version: UE 4.18
Tags:
more ▼

asked Mar 01 '18 at 03:45 PM in C++ Programming

avatar image

mcmillan_ra3
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question