x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

cannot create C++ projects in Source version, while the Launcher version is working well.

Hi, I build the ue4.18, but cannot create any c++ projects, always show me "failed to open selected source code accessor 'visual studio'"....But the Launcher version can create c++ project, and work well with vs2017.. It seems that the source version cannot recognise the vs2017, how to figure it out? Many thanks.

Product Version: UE 4.18
Tags:
more ▼

asked Mar 01 '18 at 07:18 PM in Using UE4

avatar image

shanexn
1 1

avatar image Arty-McLabin Mar 01 '18 at 07:59 PM

by source version do you mean you compiled it yourself?

did you edit anything if so?

avatar image shanexn Mar 01 '18 at 08:37 PM

Thank you for your reply, yes, I followed the documentation and compiled it, I didn't edit anything, just click the Build. The Building is successful, 0 warning 0 error... Actually I can use it create Blueprint project, but any operations associated with Visual Studio were invalid, like I'd like to open a C++ class from the UE editor, I double clicked it but nothing happend.. I changed the source accessor to visual studio 2017, not helpful..

avatar image Arty-McLabin Mar 03 '18 at 02:25 PM

i have no idea what could have cause that then. in my vanilla editor i can't access C++ too as it is bugged out, but i just use notepad++ manually, or open .sln file with vs2017 when i need.

also try to add C++ to the BP project you have made, maybe it will generate the rest of the stuff successfully and you'll be able to use C++ there.

avatar image shanexn Mar 04 '18 at 09:09 PM

Oh, thanks McLabin , hope you don't mind I call you McLabin. yes you are right, I've tried in this way, and I also tried to create a new C++ project by using the launcher version, then open it in my custom version. To some degree, it can work, but cannot open the c++ file from the UE directly, the connection between UE and VS is still broken. I tried compile it in another PC, also the UE4.18, while coming the same problem. Then I changed the version, I compiled UE4.16 with same step, it works... So I guess it might be the UE4.18.3's problem. If any other guys met the same issue with UE4.18, you may try other version.

avatar image Arty-McLabin Mar 04 '18 at 11:39 PM

i have had VS opening in 4.16 too. i am not sure about 4.17 as i skipped this version straight to 4.18 do you know if it happens in 4.17?

i would like to submit a bug report for that if it's not only me.

avatar image shanexn Mar 05 '18 at 02:00 PM

I tried 4.17 just now, no problem.

avatar image Arty-McLabin Mar 05 '18 at 02:33 PM

thank you. i've made a bug report and i hope they fix it in 4.19

avatar image shanexn Mar 06 '18 at 07:45 PM

Yes I hope so! thank you

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question