x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Animation not playing properly.

Hi,

I've encountered a weird problem when doing animation for a game. all the animation used to be working properly before, and because the texture and UV need to be updated, I imported a new model using the exact same skeleton. And some of the animations stopped working in the game, so I checked them, but everything works fine in animation preview. but when I put the animation in the blueprint, it doesn't work anymore. the animation plays correctly, the sound cue and event notification fires normal, just the model doesn't move at all. alt text the left is animation preview, it works fine, right is when I put the skeletal mesh in the pawn, directly using animation asset(looping) but the model doesn't move. I am soo confused and tried a lot of ways to fix this, but I can't find the reason. I tried to drag the animation directly into the scene, it doesn't move either. alt text animation asset setup Is there anything wrong with my animation setup? Any help is appreciated, Thanks!

Product Version: UE 4.18
Tags:
1.png (689.2 kB)
2.png (55.6 kB)
more ▼

asked Mar 02 '18 at 10:33 PM in Using UE4

avatar image

SimbaDdsa
55 8 12 16

avatar image GOAT_TomC Apr 22 '18 at 06:47 PM

I currently have the same problem. Did you find the solution?

avatar image SimbaDdsa Apr 22 '18 at 07:19 PM

Hi,

duplicating those animation seems fixed the problem for me. I still don't know what the problem was. You can try it, but no guarantee that will fix your problem.

:(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question