x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I want 4.18.4 ! Please help me !

I made a game for mobile with only blueprints. It's finished last month. But It was rejected by apple. Reason was "do not use MTLdebugdevice". I heard that it's fixed on git hub. And it fixed on 4.19 too. But I'm using plug-ins that doesn't compatible with 4.19 version. Code fix was simple. Just add two lines. So I tried rebuild engine. It needs so many space of hard drive and so much time. But I can't build my project successfully. It makes plugins problems on starting with new editor what i rebuild 4.18. And I don't know It's fixed MTLdebugdevice problem.

So, Please patch for 4.18 ! I need fixed 4.18 not 4.19 preview !

Product Version: UE 4.18
Tags:
more ▼

asked Mar 03 '18 at 10:28 AM in Installation & Setup

avatar image

titoro
31 2 5 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

you can build it from source code here :) https://github.com/EpicGames/UnrealEngine/tree/4.18

more ▼

answered Mar 05 '18 at 08:18 AM

avatar image

WindyStrife
21 1 3

avatar image titoro Mar 05 '18 at 09:29 AM

Thank you for your answer. I tried build source code and success to build. But when I open my project on new build engine, Plug-ins does not load. Because of mismatch version between engine and plug-ins. Is there any way for set version information correctly?

avatar image WindyStrife Mar 05 '18 at 10:46 AM

need C++ code to generate solution for Visual Studio or Xcode (for Mac) :D and complie it again :D i used this version is 4.18.4 from source can pass appstore ;) what plugin do you use??

avatar image titoro Mar 05 '18 at 11:19 AM

Please explain in more detail. I'm newbie of unreal engine. And I'm not good at English. Is "Generate solution for Visual Studio" means GenerateProjectFiles.bat ? If not, where can I find generate solution or how?

avatar image WindyStrife Mar 07 '18 at 06:17 AM

GenerateProjectFiles.bat will create ue4.sln :) this solution will build UE4Editor i mean you right click on you "Your Project".uproject and click "Switch Unreal Engine Version" and chose your custom build for this, i will generate new solution for you to rebuild :)

avatar image titoro Mar 07 '18 at 06:29 AM

Thank you. But My plug-ins are didn't work.

Error dialog is....

Missing Plugin

Binaries for the 'UniversalMobileAds' plugin are missing or incompatible with the current engine version.

Woud you like to disable it? You will no longer be able to open assets that were created with it.

I think the problem is my new editor program have not correct version. (Editor works fine. But plugins from markets are doesn't work.)

avatar image WindyStrife Mar 07 '18 at 09:52 AM

you can recomplie this plugin and make it work :) 4.18 all of version can work with it :D

avatar image titoro Mar 07 '18 at 09:58 AM

Is there a way to set version correctly? If fake the version of editor, Maybe I don't need recompile all plugins.

avatar image WindyStrife Mar 07 '18 at 10:05 AM

no, every version complie from source must be recomplie, they will create some dll file(on windows) or dylib(mac) to set project and plugin compatible with this version :) if plugin can work with 4.18 any version complie from source of 4.18 can work with this plugin :)

avatar image titoro Mar 07 '18 at 10:57 AM

How can I open plugins on visual studio?

avatar image titoro Mar 07 '18 at 11:47 AM

I find this. https://www.youtube.com/watch?v=WtfLfYY_k2Y And I compiled two plugins. But only 1 fail.

Error message is

Running: C:\Program Files\Epic Games\UE_4.18\Engine\Binaries\DotNET\UnrealBuildTool.exe UE4Game IOS Development -project="G:\Ue4Engine\UniversalMobileAds\HostProject\HostProject.uproject" -iwyu -module UniversalMobileAds -receipt G:\Ue4Engine\UniversalMobileAds\HostProject\Plugins\UniversalMobileAds\Binaries\IOS\UE4Game.target -NoHotReload -ignorejunk Picking the default remote server ERROR: Remote compiling requires a server name. Use the editor (Project Settings, IOS) to set up your remote compilation settings. Doing xcode-select --print-path ERROR: Failed to start local process for action ("파일 이름을 제공하지 않았으므로 프로세스를 시작할 수 없습니다."): -o BatchMode=yes ${CURRENT_USER}@ "cd \"/\" && xcode-select --print-path" Took 1.1579849s to run UnrealBuildTool.exe, ExitCode=5 ERROR: Command failed (Result:5): C:\Program Files\Epic Games\UE_4.18\Engine\Binaries\DotNET\UnrealBuildTool.exe UE4Game IOS Development -project="G:\Ue4Engine\UniversalMobileAds\HostProject\HostProject.uproject" -iwyu -module UniversalMobileAds -receipt G:\Ue4Engine\UniversalMobileAds\HostProject\Plugins\UniversalMobileAds\Binaries\IOS\UE4Game.target -NoHotReload -ignorejunk. See logfile for details: 'UnrealBuildTool-2018.03.07-20.38.29.txt' (see C:\Program Files\Epic Games\UE_4.18\Engine\Programs\AutomationTool\Saved\Logs\UAT_Log.txt for full exception trace) AutomationTool exiting with ExitCode=5 (5) BUILD FAILED

like this.

Maybe It needs remote build with iOS. My Mac can remote build with windows unreal editor. But It can't run unreal editor on mac self (It's old model.) Do you know how can I remote build with automation tool?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It's not solved to me. But I'm giving up.

I don't know how can I make a custom build and use correctly.

Maybe It's easy to C++ programmers. But It's too difficult to blueprint only worker.

Anyway Thanks alot 'WindyStrife'. You are so kind.

more ▼

answered Mar 09 '18 at 11:37 PM

avatar image

titoro
31 2 5 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question