x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot seem to get game to load on Start

I am really stuck and I have no idea how in the world to fix it. I have been stuck on this part for like 5 hours now today and after trying and trying and trying nothing is working..

I have a simple runner game. I set the gamemode to "rungamemode" in the maps and modes under project settings.

I then created a second game mode called "rungamemenumode" and stuck the main menu widget and hud stuff in there with it overriding the rungamemode until the game is started after clicking start game on the game menu.

If I do click on start button open level nothing happens, it just sits there on the menu and the game never plays. If I change that to remove from parent then it works partially but the game never starts, it just sits where the game would start up to begin playing in the game world.

There's nothing on the game level blueprint and there's also a runhud with the player in-game ui that's cast to the player and that seems to work at least but I cannot figure out why it's not working after looking through it for several hours alongside countless youtube tutorials about it. I could do a 3d menu from my other game which I have it working in but I don't want that for this game project and it doesn't make any sense to me here.

Any ideas? I am really lost here and I need help please! It's probably right in front of my face too.. -_-

SCREENSHOTS of my BPs: alt text alt text alt text alt text alt text

Product Version: UE 4.18
Tags:
more ▼

asked Mar 03 '18 at 09:25 PM in Blueprint Scripting

avatar image

Deygus
108 11 21 21

avatar image ThompsonN13 Mar 03 '18 at 10:45 PM

where do you change game modes? unless im missing something its not shown there.

avatar image Deygus Mar 03 '18 at 11:16 PM

Come to think of it I don't know if I am even doing that right but I was trying to figure it out better without help and have been stuck.. I got so frustrated I decided to step away from it for a little bit until I could clear my head. It's probably something that I am missing or doing wrong somewhere :/

I think at the moment I am just changing the game mode in the world settings for the Game Mode Override. Not changing it anywhere else aside from having the default level game mode be what I had originally.

Anyways, I was trying to figure out if there's an easy way to switch it over after loading the level but I was struggling to figure that out.

Basically I followed the UE4 Endless Runner Tutorial which I completed and then changed over to my own assets.

After that I followed this guy Virtus's Menu System Tutorial and that had me creating a MainMenuHUD and duplicate the existing Game Mode that I had (RunGameMode) which I then renamed as (GameRunMENUMode) and then in the Game World Settings I changed that to override the game mode to disable the character controller but I have a MainMenuWidget being attached to the viewport with it when the game launches.

On the other hand I have the game's RunHUD which is in the game mode being casted to the RunCharacter aka the player when the game starts and I had both of those as the project default. I even tried switching it up but no luck or else I am doing it wrong.

If I use Open Level then it just stays on the Main Menu and nothing happens. If I use Remove from Parent that works and loads the game but instead of the game playing it just shows the camera sitting there in the game world with nothing happening or playing. It's kinda strange almost like the two game modes are trying to override each other or something.

I tried to remove and fix it but no luck yet.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question