x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG Text Not Displaying Proper Value

I have multiple sub-nested UMG UI widgets that are dynamically generated by pulling data from a DataTable. Everything else is working fine, only thing not working is getting the name of the items in the collection to display their name. For some reason it's adding other random characters to the end and only displaying part of the value.

To give the attached pictures some context, I have a UI widget that loops through all the different Collection DataTables I have and populates the "Collection" widget. The "Collection" screen widget then loops through all the data within it's particular DataTable and populates itself with all the items (e.g. CapName and CapTexture). CapTexture is displaying the texture properly and as you can see during the PrintString, it's displaying the proper title of the CapName on screen, but then when displaying this inside of a Text widget, it only prints the "Common" part properly, then sometimes nothing afterwards and sometimes it adds random characters (D, E, M, O, etc...). Even stranger that the values spell out "DEMO" lol Everything in each sub-widget is being set on Event Construct.

No clue why.. Any ideas? Thanks in advance.

alt text

Product Version: UE 4.18
Tags:
more ▼

asked Mar 04 '18 at 08:41 AM in Blueprint Scripting

avatar image

Element808
31 1 3 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Fixed it!

It happened to be that the font I was using, didn't have numbers within it and it spelled out 'DEMO' where 2, 3, 4 and 5 were supposed to be. Lesson learned.

Hope this will help someone else, who may run into this issue in the future.

alt text

more ▼

answered Mar 04 '18 at 09:58 AM

avatar image

Element808
31 1 3 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question