Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Problems with FBX animation: curve information discarded, keyframes removed, animation too fast

I'm having so many problems with this animation that I'm sure I must be missing something.

Attached here is a .3ds and matching .fbx file for a lever I'm trying to animate with a single bone. I exported the .fbx file in ASCII format just to double-check that things were getting exported as I expected. The animation is in four parts: a default pose, an untransformed pose, a down animation, and an up animation.

The first issue is that after I import the animation, Unreal reports that the animation has 6 frames, but the .3ds and .fbx files both have 9 frames.

Second, the animation seems to have discarded the curve information. Here's a comparison of the curve I expected to see (green) and the curve that appears to be happening (pink):

alt text

The two rest poses should clearly remain stationary, but Unreal gives me a smooth animation. The little notches at the end of the up/down animations also seem to be missing. At first I thought Unreal was ignoring the stepped curve types, but the notch at the beginning of the down animation is just an ordinary spline; it's a little bit more subtle, but it appears to be missing as well.

Finally, the animation is running too fast! Unreal recognizes that the animation should be 5s long, but it runs through the whole thing in about 4.6 seconds, and then remains stationary for the last 0.4s.

These problems all seem to be solved if I export with the "Bake Animations" and "Resample All" options, but then I get 151 keyframes, which isn't exactly optimal.

Is this a PEBCAK issue, or am I hitting multiple bugs?

Using Unreal 4.3.1 and 3ds Max 2015.

Product Version: Not Selected
levercurve.png (44.6 kB)
lever.zip (25.1 kB)
more ▼

asked Jul 30 '14 at 06:56 AM in Using UE4

avatar image

41 2 4 9

avatar image Douglas Lassance Oct 08 '14 at 02:51 AM

Did you find a solution to your problem yet? It seems pretty related to my question.

avatar image Skrapion Oct 08 '14 at 03:07 AM

I ended up just "Bake Animations" and "Resample All". I'm not sure if Maya's FBX exporter is any different than Max's, but those options basically just export a keyframe on every single frame, instead of relying on the curves.

avatar image Douglas Lassance Oct 08 '14 at 03:56 AM

Maya has pretty much the same options. Baking per frame solves the smooth interpolation that is happening between key-frames but not the one between frames. This is what I am trying to fight since the engine will try to display sub-frames.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You can freely use the "Bake Animations" and "Resample All" options. The UE4 FBX importer samples animations at an uniform rate anyway, because later on, during the creation of the runtime data for the anim, the frames are reduced as much as possible and then compressed.

more ▼

answered Jul 31 '14 at 01:00 AM

avatar image

188 24 31 144

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question