x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Incorrect shadows on the wall mesh

Hello guys,

Can anybody help me with this problem? Working on this archviz scene and after many steps taken for the lighting setup I got some unexpected result on some spots on the wall. alt text

As you can see on the picture, there is some kind of incorrect shadow or shadowing spots that appeared after few light builds. I tried to reset some of the lighting settings but nothing is changing. The light map resolution for the wall mesh is 1024. Any advice is welcome.

Thank you!

Product Version: UE 4.18
Tags:
incorect-shadow.jpg (287.6 kB)
more ▼

asked Mar 05 '18 at 05:11 PM in Using UE4

avatar image

anetopuceto
19 6 9 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi, sorry for the late response, I did mostly of the things that you mentioned but nothing was changing, so I did some research and the problem was "texture streaming pool over", I increase the streaming pool size and the blurry spots on the wall disappeared. Thank you for your help.

more ▼

answered Mar 10 '18 at 08:10 PM

avatar image

anetopuceto
19 6 9 15

avatar image Makigirl Mar 10 '18 at 08:19 PM

No worries I'm glad you solved it! ;)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi!

I don't know what look/quality you're after... I guess you've lowered the indirect lighting scale (and smoothness maybe) to get more detail for your render... and maybe haven't increased quality? I'd say if you raise the quality (8-10) you should get rid of those... If you're not after photoreal you can set scale and smoothness to 1 and I guess they'll disappear... Can you show your lightmass settings?

more ▼

answered Mar 05 '18 at 05:31 PM

avatar image

Makigirl
1.3k 4 4 8

avatar image anetopuceto Mar 05 '18 at 05:44 PM

I'm trying to accomplish photorealism and here is the lightmass setting... alt text

avatar image Makigirl Mar 05 '18 at 05:57 PM

Hi!

I'd lower the scale to 0.1 if you're after photoreal. Bounces to 5-10 both of them. Quality to 8-10... And turn OFF compression!! Do you use portals in your scene?

ps: Do you have a skylight in your scene? /it's bounce is set only to 1 so you won't get GI from it really...

avatar image anetopuceto Mar 06 '18 at 12:33 PM

Hello again, I tried fixing some of my lightmass setting as you suggested and here are the results:

alt text

alt text

And yes, I have skylight in my scene and also lightmass portals but i didn't quite understand, I should turn off "compress lightmaps" if I'm using portals? Btw the building time is much longer now, and turning off compression will make it even longer, right?

avatar image Makigirl Mar 06 '18 at 03:24 PM

No they don't have any relation but they both can cause "dirty" lighting! I think turning off compression on lightmap might even speed up the process a bit! ;) Your longer building time is because of the quality setting! So please turn off the compression! This alone might solve the problem! What I would do in your case to speed up the process: set all other asset's lightmap resolution really low and leave high on this wall only! I would also turn off all lights except your two main lights: skylight and directional light! I haven't seen any of your lights' settings... please try to turn off anything not necessary (any extra tweaks except intensity which should be around 3...) You can also lower your indirect lighting quality to somewhere around 2-4 and build your scene in medium... you will see more artifacts but if you see "through" it you will see if the lighting got more real or not! It it gets better then you can turn back on things on raise your quality settings! Hopefully it will help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question